Our forums are currently in maintenance mode and the ability to post is disabled. We will be back up and running as soon as possible. Thanks for your patience!



Wierd Canon MF4350d USB Problem

I have a client that has a Canon ImageClass MF4350d connected to a computer running Windows 7 Professional. The printer is not sitting next to the computer and needed a 15 foot USB cable to connect to the computer.

Well there was a strange problem that I had never seen before and wanted to know if anyone has run into the same problem.

The problem was when you used a 15 foot or longer USB cable to connect the printer. The printer would print perfectly fine but it refused to scan anything. It would freeze any program you tried to scan from. I tried about 10 different USB cable all with the same result. Multiple brands and multiple lengths of at least 15 feet.

I did get the printer working perfectly fine but I needed to use a 10 foot USB extention cable (Male\Female)with a 5 foot USB cable in order to get it working.

If anyone has had a similer problem let me know.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

I recently had a bout with electromagnetic fields.

by Ron K. In reply to Wierd Canon MF4350d USB P ... <br>

It wasn't with USB though. Mine was with a monitor that showed shadowing. I was using a 10 foot unshielded VGA cable. There's enough wiring here that I got crosstalk from it. As soon as I put on a shielded cable everything was fine. <br>
You could be having the same sort of problem with electromagnetic interference on your USB cable. It's right close to the maximum recommended length. If you were able to set everything out in a straight line, away from the possibility of interference, it wouldn't surprise me if you could scan.

Collapse -

I would have a talk to cannon here

by OH Smeg Moderator In reply to Wierd Canon MF4350d USB P ...

And get a Ethernet Board fitted if there isn't already one and use a CAT5-6 Cable to connect this printer rather than a USB Cable.

The system works better and doesn't run into any problems with USB Interference. You just setup the Image Runner Copier as a Network Printer and they work a treat. I've been using a IR 3100 that way for years from new for one client and several of the newer ones in the same manner.


Collapse -

Same problem

by maydaygames In reply to Wierd Canon MF4350d USB P ...

We tried a firmware update and it did no good. Then we went and bought a 6 Ft cord instead and it worked like a charm. Weirdest thing I've ever seen. How can that even be the problem? Solved anyway. Thanks for the hint!

Collapse -

Wierd Canon MF4350d USB Problem

by amazon43 In reply to Wierd Canon MF4350d USB P ...

I just installed a new MF4350d on a 64 bit windows 7 Professional. The computer refused to recognize the Canon MF but has no problem recognizing a HP printer. I have swapped cables and reinstalled the software several times. No luck at all.

Collapse -

Download the latest 64-bit driver from Cannon

by seanferd In reply to Wierd Canon MF4350d USB P ...

By "refused to recognize", do you mean that no new hardware is detected at all in Device Manager, or just that the driver won't install?

Collapse -

As stated above get the newest Canon Drivers

by OH Smeg Moderator In reply to Wierd Canon MF4350d USB P ...

The reason that the computer is seeing a HP unit is that Canon sell their Printer Engines to HP and the computer is making a mistake identifying the printer.

If I remember correctly you need to install the Driver and then when prompted plug in the printer or if it's plugged in turn it on. Do Not plug in the running printer till after the driver is installed.

Related Discussions

Related Forums