Our forums are currently in maintenance mode and the ability to post is disabled. We will be back up and running as soon as possible. Thanks for your patience!



Windows cannot access specified device, path or file...

By branty1970 ·
I have a problem that has developed on my user account. When I try to open any EXE file or MDB file on a network drive I get the following message.

Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item.

I can open other file types without a problem - even files in the same folders as the problem files.

I've double checked the permissions and I have full control on all the files in the folder.

I've run a full virus scan on the machine and there are no viruses (the pattern file and engine are up-to-date).

I've scanned the machine with the latest versions of Windows Defender, SpyBot and AdAware.

I've checked the problem from another machine and it follows the user account.

If I copy the file to a local (C:) folder I can run it without any problems.

I'm pulling my hair out with this one. Has anyone got any other ideas??

I'm running Windows XP Pro SP2 with all the latest patches and fixes.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Check Firewall

by CaptBilly1Eye In reply to Windows cannot access spe ...

Hi Branty1970,

I had a similar issue on a network setup. It turned out to be a ZoneAlarm firewall setting.
Check file type permissions in the firewall(s).

Collapse -

I've given up!

by branty1970 In reply to Windows cannot access spe ...

OK, I've managed to show it's definitely a profile issue but I cannot find the cause. So here's the solution I came up with.

Backup the profile from the server.
Rename the original user account.
Create new user account with same user name.
Logon - this creates a new profile.
Check that the problem has gone away.
Copy parts of the original profile I can't do without back into the new one (internet and mail setup).
Final check that everything works OK.

I've only found one problem so far. The original issue seems to have stopped the desktop from synchronising with the server. The work I'd done and saved on the desktop was lost when I deleted the original profile from the workstation! Fortunately not too much, but a pain anyway.

Collapse -

Were they copied?

by CaptBilly1Eye In reply to I've given up!

If user privileges are set right, I have seen that message when a AV program or firewall is blocking access. But I'm sure you've checked that thoroughly.
I'm just wondering... were the files in question originally copied from another drive?
Right click on the file and choose "Properties" and look to the bottom of the "General" tab. Here you should find an "Unblock" button provided to allow normal access to the file.
This will also cause the error message you're getting. This is due to a flag placed on the file as a result of being moved from another computer or network.

BTW.. files saved to the desktop will be lost when a restore is performed as well.

Collapse -

Nice One! Thanks!

by darren5972 In reply to Were they copied?

That sorted my problem, thank-you

Collapse -

That's exactly my situation.

by hisham_m_farid In reply to Were they copied?

Thanks a lot, it was new to me, and works.

Collapse -

You are awesome

by markrosoft57 In reply to Were they copied?

Thank you so much. I had the same problem and that saved me alot of headache.

Have a great weekend.

Collapse -

Thanks! Problem resolved.

by lal In reply to Were they copied?


Thanks! Your solution solved my problem. I had copied the installation files from some other computer and I was getting Access Denied message. Ublocking the file, sorted out the problem.

Collapse -

Windows cannot access the specified device, path, or file

by tverdey In reply to Windows cannot access spe ...

The problem is Internet Explore 7, but I don't know how to fix it without having to reinstall and not use IE v7.

Collapse -

The Solution for this problem ( an easy work around)

by amigoaria In reply to Windows cannot access the ...


I just added the network drive to the trusted sites list, you can find it from tools\internet options, then select the security tab.

Hope that solve it for you too :)

Collapse -

windows cannot access the specified device

by deanna.leimbach In reply to The Solution for this pro ...

I am having this same issue and I also believe it has something to do with IE7 because I didn't have the problem until I upgraded. I tried adding my network drive to the trusted sites list in IE but that didn't solve my problem.

Anybody have any other suggestions?

Related Discussions

Related Forums