Okay, I have a serious problem. My exchange server 2003 has dismounted the mail and public store databases and refuses to mount them back on and give an erro message to “restart the system manager or information store services or both”. All the services are running properly. The hard disk where the databases sit has enough space. The only problem I can see is that the database size is 15GB. Defragmentation, repair, recovery don’t work because of a corrupted or missing log file. There are no backups of the system and I am totally puzzled.