General discussion
November 21, 2005 at 12:37 AM
jaak.stappers

Rollback a DTS-package

by jaak.stappers . Updated 20 years, 10 months ago

Hello
We run several DTS-packages on an SQL server 2000 during the night.
Each package updates several tables by first dropping them, then creating new instances and finally copying the data from the source into them.
The problem is that the connection to the source is established after the drop and the creation. So, when this connection can’t be established, the new tables contain 0 records.
Can somebody tell me how I can rollback the package or how I can test on the connection the source prior to the drop and creation and cancel the package if the connection fails.

This discussion is locked

All Comments