I administer a W2k server running exchange 5.5 SP4. Lately some people have compalined that messages sent to my domian have bounced back. There is no clue in the bounce that I have seen why it occured.
Here is one of the bounces
From: postmaster@mail.hotmail.com
>To: xxxxx@hotmail.com
>Subject: Delivery Status Notification (Failure)
>Date: Sun, 18 Jan 2004 17:57:25 -0800
>
>This is an automatically generated Delivery Status Notification.
>
>Delivery to the following recipients failed.
xxx@XXX.com
Ive noticed that I have no Reverse DNS entries for my MX records. Could this be the cause of the problem?