I have a remote office that has its own domain on a Windows 2000 Advanced Server with AD. The workstations that are presently connected to this doamin are Windows ’95, ’98, ME and 2000 Prof workstations. The main office is a mixed network running NT4.0 which is my PDC and Windows 2000 Servers. Now they want to combine the 2 networks into 1 over a T1 line. The problem is they only gave me one weeks’ notice, so I configured a NT 4.0 BDC for the remote office. First of all, was this the proper thing to do? After downing the original domain with Windows 2000 Server and AD installed, I connected the NT 4.0 BDC. The Windows ’95, ’98 and ME workstations were able to connect to the domain (BDC), but I was unable to connect the Windows 2000 Prof workstations to the domain. Does this have anything to do with the AD installed onto the original domain? Please help?