Networking

Use Multilink PPP to combine multiple circuits into a single circuit with a single router interface

David Davis explains how Multilink PPP works in combining multiple circuits from the same Internet provider into a single circuit. He also shows you how to configure a Cisco router to handle this setup.

At my company, we initially started out with a single T1 for Internet access. That gave us 1.5Mb up and 1.5Mb down. Over time, we outgrew the 1.5Mb down as we added more users. We had to add more bandwidth; however, it was not cost effective to bring in a DS3 or fractional DS3 for Internet access, just to add one or two more T1 circuits. Also, we wanted the circuits to act as a single circuit, not two or three independent circuits. We ended up ordering two additional T1 circuits in a multilink PPP bundle. Later, we added one more T1 circuit. With a total of four T1 circuits for Internet access, this gives us a total of 6Mb of Internet bandwidth (6Mb upstream and 6Mb downstream). But how do you configure four T1 circuits to act as one? Find out how Multilink PPP can help.

What is Multilink PPP?

PPP is a standards-based protocol based on a RFC (Request for Comments document); Multilink PPP is also a standard based on an RFC. Specifically, Multilink PPP is based on RFC2686 - The Multi-Class Extension to Multi-Link PPP and RFC 1990 - The PPP Multilink Protocol (MP).

The point of Multilink PPP is to take multiple PPP links and "bond" them together to act as a single PPP link. These PPP links that are being bonded could be an ISDN BRI circuit, T1 circuits, or other types of PPP circuits. You should know that Multilink PPP must be configured on each side of the link. Thus, you cannot get multiple PPP T1 circuits from multiple carriers and expect to run Multilink PPP across them. All Multilink PPP circuits must come from the same carrier.

Multilink PPP is not something new; it has been around for a long time. However, in the past it was primarily used to bond together multiple, slower dial-up circuits (like ISDN circuits). While I am sure there are plenty of companies out there still using Multilink PPP with dial-up connections, it is now more common that Multilink PPP is being used to combine multiple circuits of T1 or higher bandwidth into a single circuit.

How do you configure Multilink PPP?

Given that the two sites that are connecting via Multilink PPP communicate with each other and coordinate the configuration, configuring Multilink PPP is easy. Here is a sample configuration of four T1 circuits being bonded to form a single 6Mb Internet circuit:

controller T1 0/0/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
controller T1 0/0/1
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
controller T1 0/1/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
controller T1 0/1/1
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
interface Multilink1
 ip address 1.1.1.1 255.255.255.252
 no cdp enable
 ppp multilink
 ppp multilink group 1
!
interface Serial0/0/0:0
 no ip address
 encapsulation ppp
 no fair-queue
 ppp multilink
 ppp multilink group 1
!
interface Serial0/0/1:0
 no ip address
 encapsulation ppp
 no fair-queue
 ppp multilink
 ppp multilink group 1
!
interface Serial0/1/0:0
 no ip address
 encapsulation ppp
 no fair-queue
 ppp multilink
 ppp multilink group 1
!
interface Serial0/1/1:0
 no ip address
 encapsulation ppp
 no fair-queue
 ppp multilink
 ppp multilink group 1

This configuration is from a Cisco 3845 router that has Qty 2 VWIC-2MFT-T1 interfaces. These T1 controllers create the Serial0/0/0, 0/0/1, 0/1/0, and 0/1/1 interface that are bound to the multilink group #1.

It is the multilink1 interface that is actually the single combined interface that really has the "6Mb" of bandwidth, and that is where you would apply all of your "normal interface configuration" for this 6Mb connection that connects to the Internet. You can see how the multilink 1 interface has an interface number that matches the ppp multilink group. On that multilink 1 interface, you have the IP address for this link, an ACL on the interface, firewall, NAT, or other Internet public router interface commands.

By using the multilink interface, you are able to bond all four of these T1 interfaces into a single router interface -- very cool!

To verify that your multilink interfaces are up and running, you can use the show ppp multilink command, like this:
Router# show ppp multilink

Multilink1, bundle name is MY-ISP
  Endpoint discriminator is MY-ISP
  Bundle up for 10w0d, total bandwidth 6144, load 25/255
  Receive buffer limit 48000 bytes, frag timeout 1000 ms
    2/3020 fragments/bytes in reassembly list
    204716 lost fragments, 310561297 reordered
    474999/517174257 discarded fragments/bytes, 474999 lost received
    0x256CD0 received sequence, 0x2071C9 sent sequence
  Member links: 4 active, 0 inactive (max not set, min not set)
    Se0/1/1:0, since 10w0d
    Se0/1/0:0, since 10w0d
    Se0/0/0:0, since 10w0d
    Se0/0/1:0, since 10w0d
No inactive multilink interfaces

Router#
The key to configuring Multilink PPP is the multilink interface, the ppp multilink protocol on each router, and the ppp multilink group x command on each interface. Multilink PPP isn't a difficult router configuration to set up, and it is extremely valuable when you need multiple circuits bonded into a single circuit from a single provider.

Want to learn more about router and switch management? Automatically sign up for our free Cisco Routers and Switches newsletter, delivered each Friday!

22 comments
gtx426hemi
gtx426hemi

T1 are getting old fashioned like dial-up

betinholhes
betinholhes

I`ve configured PPP multilink at my company using three E1 (2 Mbps, Brazil), but i??ve had problems with it. Even when the load was lower than one E1, the traffic was too slow, and with a simple debug command, the cpu load was huge and it stopped the router (Cisco 3600). Does anybody knows what may have happened? Thanks

jayshow
jayshow

How is bandwidth shared? Are packets sent over individual physical interfaces of the multilink bundle, multiple packets in parallel, to achieve aggregate bandwidth? Or, are packets broken into smaller units and sent out across all available physical interfaces?

Photogenic Memory
Photogenic Memory

By bonding 3 T1's; does that make the bandwidth increase or is it just for redundancy,or is it simply HSRP( Hot Standby Routable Protocol )? Apologies for the confusion. Also, this is only about software configuration so far. How do you punch these lines down together? Do you punch them into a 110 block or a 66? If so; how and in what color/ring/tip sequence? If you don't know how to do it; then who do you contact ot find out? It's a great article but pieces are missing. Please update?

JoeBeckner
JoeBeckner

Has anyone had experience with Multilink PPP on two T1's between different vendors routers. I have a case where the data center has a Cisco 3825 router and the ISP has Juniper router. I am concerned about the reliablity. I know its supposed to be standard per the RFC spec, but...

chenoufimehdi
chenoufimehdi

HI it's nice to know how ton configure PPP multi link but it will be very nice to know why we do that and what's the adventage of doing it...could some boyd explain please? regards

richard
richard

I like Multi-WAN routers. I just think plugging CISCO and no one else is funny. I would like to see more open source products instead of the same old CISCO and HP products. Everyone should take a serious look at a Linux Distro called "Clark Connect". The free version doesn't have PPP support, but the pay versions do. The lower price version is $75/year (includes updates). I'm using this to bring in 1 T-1 and 3 Wireless signals for a grand total of around 15Mbs. It does automatic failover, load balancing and MUCH more! It isn't just a multi-wan device either, it has many more features. More products to mention are IPCop, m00nwall and Untangle.

nsbetts
nsbetts

This works pretty well, we are using it for several branch offices and internet connections as well. We are lucky enough to have fiber to most locations so we don't have many issues with circuits dropping, but at our locations with copper circuits, users don't even notice when a circuit drops.

bhoskinson
bhoskinson

what happens if one or more of the bonded circuts drops, say some half cocked trunk monkey unplugs one or something else stupid happens that doesn't take out all the circuts? Does the connection continue with less available bandwidth?

brian
brian

"Who needs multiple T1 when you can do better with cable modems? T1 are getting old fashioned like dial-up" I would change this to say who needs T1's when you can do better to fiber/ethernet handoffs. Cable modems are a decent solution to smaller companies (maybe) but I would never trust them for mid to large companies except for WAN failover. plus, the asynchronous nature of download/upload of cables modems become a detriment with serious bandwidth needs. but hey, at least it's not DSL.

Photogenic Memory
Photogenic Memory

How is a T1 on the same level as a dialup connection? Are speaking about internet over cable media perhaps? If so; then it's here to stay despite the achievements in making wireless networks better and larger coverage bubbles. So what are you hinting at that's much better? Please respond with some examples? Thank you

Vinnie1733
Vinnie1733

Do the E1 connections all terminate into the same router (Cisco 3600) ? What do they terminate into on the otherside? The same router ? What kind of route is it?

manfmmd
manfmmd

It is not considered HSRP. There is redundancy however built in if a single T-1 goes down, the others in the group will continue to carry the load at a reduced bandwidth capacity. You bandwidth will look like 4.5 Mbps in a 3 T-1 setup. The LEC should deliver the T-1's on a smartjack, so in most circumstances with structured cabling in place, there would be no reason to lay them down on a 66 or 110 block. If you were to need to lay them down on a 66 or 110 block, simply punch them down pair for pair, there is no crossover needed.

adewalexdavid
adewalexdavid

And good questions from Adam, that might need to be answered. Thanks

Vinnie1733
Vinnie1733

MLPPP bonds circuits at layer 2 and uses a logical interface as the router interface. I would also add that the statement single router interface needs to be clarified. If you have 3 T1 for example, you will have 3 T1 physical WAN interfaces. The single router interface refers to a logical interface on which the link IP address would be configured and across which traffic would be routed. Benefits: 1. better used of IP address space. 2. The router considers the bundles circuits as an aggregate connection versus seperate connetions using load sharing at layer 3. 3. As a circuit drops, the ciruit should drop or add with out impacting the service on the other connections.(Theoretically)

JoeBeckner
JoeBeckner

The advantage is that it combines two (or more) T1 lines (or other serial lines ) for load balancing, plus if one fails all traffic is sent over the other line automatically.

chenoufimehdi
chenoufimehdi

if you just unplug one link from the bundel the multilink will continu to work with less bandwidth but there is something that you must know in practice I've seen it going very bad when one of the bundel's link start to show a lot of errors the multilink may not drop down but it will be unusable and the performance will be significantly decreased

Franko0115
Franko0115

If one or multiple T1's drop off the multilink group you will just see a reduction in BW, but the remaining T1's should not be affected. You can run show ppp multi int multi(enter your multilink name or #) to check out the status of your other T1's. Once your T1 is back in service it will be automatically re-entered in your multilink group.

brian
brian

if one of the circuits drop there is no interruption in service. the connection continues on with diminished bandwidth. when you run 'show ppp multilink' it will show one of the circuits being active. we had this issue at a remote site where apparently no one thought to check the cable to the smartjack. that's another benefit of multilink as before it was setup as multilinked it was just three separate T1's with default routes to each T1 (don't ask) which would cause issues when one went down and it was doing round robin on the routes. with multilink you would have to lose all circuits before the interface would go down.

betinholhes
betinholhes

The other side we have a Cisco 1750. Three E1 connections on three serial interfaces at the same router in both sides.

Franko0115
Franko0115

Brian, I currently use Multilink PPP for all of my T1 circuits and sometimes run into a problem with errors coming from my individual interfaces which causes a minor alarm condition on my T1. This results in reduced bandwidth as the T1 is automatically configured to remove away from its associated MultiLink group once it is in trouble. I have 10K cisco routers. Any commands/procedures you would recommend that I can run on these interfaces? I know I can put a loop on the T1 facing the router interface,clear my counters and watch for incrementing CRC errors, input errors etc.. I often have to have to reassign a new router interface to clear the condition, but this is getting out of hand. Thanks

brian
brian

I don't have a lot of experience in specifically troubleshooting Multilink issues beyond normal LAN/WAN troubleshooting. I would log the errors manually and try to determine if it a certain set of routers causing the issue or perhaps if they are coming from the same vendor (Qwest, Verizon, etc.). Most of the issues I have dealt with regarding Multilink interfaces have been physical issues (smartjack) and a couple clocking issues on the T1 cards.

Editor's Picks