Question

Locked

Application not launching from a login script

By ron_jeff ·
Hi All

I'm having this wierd scripting problem and am wondering if anyone else has experienced the same problem.
I have created a login script to map drives and launch a java application. When I run this script locally, it executes and completes successfully. However, if I run it from a w2k3 domain, the drives will map but it will simply not launch the java app. I initially thought it was to do with the script launching the app before the drives had mapped, however, I put a loop command in to loop the script until the drives had mapped. This still did not solve the problem.
Anyone have any suggestions?

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

And the code is

by JPLconsultant In reply to Application not launching ...

It's kind of hard to troubleshoot code without knowing what it is.

<insert code here>

Collapse -

The code is

by ron_jeff In reply to And the code is

Here is the .BAT file code.......

echo "--> Deleting existing network drive mappings"
net use * /delete /y


echo "--> Mapping COMMON to H:"
net use h: \\server02\common
echo "--> Mapping SERVICES to I:"
net use i: \\server02\services


:loop
if exist I: (goto Sonar) else (ping 127.0.0.1 -n 10)
goto loop

:Sonar
i:
cd \SonarAuthStartApp\
start javaw -jar SonarAuthStart.jar

Collapse -

Paths

by scott_heath In reply to The code is

Start by using the full paths to java.exe and SonarAuthStart.jar.

Collapse -

Policy Setting?

by JPLconsultant In reply to Application not launching ...

Since the script works locally, but not when connected to the domain, I wonder if there's a Group Policy Setting that's in play. Are you sure you've got the user profiles configured correctly to run a startup script? Checked security permissions being set by the GP?

Collapse -

RE: Policy setting

by ron_jeff In reply to Policy Setting?

Well, since it is mapping the drives when logging in to the domian, it means that the clients are configured correctly. I don't recall a GP security setting that prevents this. Does such a setting exists to disallow java applications to run from a login script.

Collapse -

Not sure

by JPLconsultant In reply to RE: Policy setting

Off hand, I don't of a GP setting to disallow java, specifically.

Did you try specifying the full path, as suggested earlier?

Back to Software Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums