General discussion

Locked

Can't install any Network Adapter Device Manager Code 31

By ggreayer ·
I have a strange Network problem with Windows XP Pro SP2 Network Adapter install. I can't use any network adapter (including 1394) Device Manager has all NICs yellow-flagged and show Code 31 (the drivers cannot be loaded.) (Intel Pro 100/1000 82575EB) If I UNINSTALL (it fails the uninstall) it and try to re-install it (or any other NIC), after copying the files the wizard fails with "System cannot find the file specified." In the setupapi.log it fails on the ClassGUID load. I am installing the newest drivers and tried using multiple NICs. I have spent an enormous amount of time to no avail, but I need this system for work and a full wipe & reload is not an option at this time, over 250 applications installed (seems like there should be a fix.) I have tried a Repair Install which did not fix it.

I have seen others with this same problem online but no one seems to have found a fix.

I have gone deep into the registry tracing thru the PCI sections and Class and CLSID sections. I have deleted everything pertaining to the NIC and then reinstalled and got the same result. This is a new computer with a SuperMicro MB X7DWA-N 8-core. If I boot off a second HD the NICs work fine.

This is NOT a Driver problem, I have the latest. It is some kind of damage to PnP or PCI or Network Adapter install probably at the INF level. Though I have tried deleting all the Oem???.inf's related to the Nic. Same result with reinstall.

Can anyone help me?

Thanks!
Gregg

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

...me too

by mmarsten In reply to Can't install any Network ...

I am having the exact same problem.
Same exact symptoms...

Collapse -

Can't install NADM code 31

by PaulLP In reply to Can't install any Network ...

Uninstall toolbars on your computer, especially if its a video, TV or music toolbar download, there maybe connect conflict. Uninstall network adapters; uninstall example: (Realtek Wireless 54Mbps NetAdptr),reinstall Wireless(brand)PCIE NetAdptr. Restart computer. Try That! Thanks paul709

Back to Software Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums