Question

Locked

CGI, perl not working on ubuntu 14.04 web server

I am facing a problem quite a while. I set up ubuntu 14.04 server with apache2 in my home network. It was working fine, even CGI perl was working properly. I did update and upgrade. After that my cgi program does not work from http://10.1.1.3/~<username>/cgi-bin/perltest.pl

I left no stone unturned to solve the problem. However, I could not find any solution. I follow the link
http://www.ubuntugeek.com/how-to-install-apache2-webserver-with-phpcgi-and-perl-support-in-ubuntu-server.html.
Aslo other referel from google search. But my problem remains same. Below is my log file and site configuration file of my problem. With this configuration perl program on my web server setup was working fine. I will be grateful if someone give me a solution.

/var/log/apache2/error.log

Sun Mar 01 11:29:54.136602 2015] [mpm_prefork:notice] [pid 4792] AH00173: SIGHUP received. Attempting to restart
[Sun Mar 01 11:29:54.167266 2015] [core:notice] [pid 4792] AH00094: Command line: '/usr/sbin/apache2'
[Sun Mar 01 11:30:32.484631 2015] [mpm_prefork:notice] [pid 4792] AH00169: caught SIGTERM, shutting down
[Sun Mar 01 11:30:33.544978 2015] [mpm_prefork:notice] [pid 4877] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.6 mod_perl/2.0.8 Perl/v5.18.2 configured -- resuming normal operations
[Sun Mar 01 11:30:33.545002 2015] [core:notice] [pid 4877] AH00094: Command line: '/usr/sbin/apache2'
[Sun Mar 01 11:32:15.771736 2015] [authz_core:error] [pid 4881] [client 10.1.1.8:49463] AH01630: client denied by server configuration: /home/favicon.ico

My /etc/apache2/sites-enabled -configuration file.

<VirtualHost 10.1.1.3:80>
ServerAdmin admin@greentank.des
ServerName greentank.des
ServerAlias www.greentank.des
DocumentRoot /home/greentank/public_html/
ErrorLog /home/greentank/logs/error.log
CustomLog /home/greentank/logs/access.log combined

#ScriptAlias /cgi-bin/ /home/greentank/public_html/cgi-bin

<Directory /home/greentank/public_html/cgi-bin>
Options Indexes FollowSymLinks
Require all granted
AllowOverride options
#Options
Options ExecCGI
Require all granted
AddHandler cgi-script .cgi .pl
</Directory>
</VirtualHost>

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Share your knowledge
Back to Windows Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums