Question

  • Creator
    Topic
  • #2150275

    Comcast internet and router troubles

    Locked

    by jay ·

    I’ve spent hours today and the days prior trying to get both my Macs
    up on the internet at the same time. I can get either one to work
    independently through the router, but not together. My Vonage isn’t
    working either, but that’s another matter.

    So, a new Comcast approved Motorolla modem and Linkseys router
    (thanks to Mark) later, I’m still not getting both computers to work on
    the internet at the same time. (They used to, before our router went
    bad). We thought it was the modem so replaced it first.

    Here’s the configuration: Comcast Cable into utility room > Cable
    Modem in said room > to wall outlet upstairs in kitchen > to router >
    to phone modem and upstairs and downstairs computers.

    Comcast hasn’t been real helpful. They did come and determine that
    the router was the problem though.

    From my investigation I see that I cannot have an IP address beginning
    with 169. and that Comcast assigns an IP address each time I start up
    one of the computers. The router though is supposed to create a fake
    number so that the modem (or Comcast) only sees one computer.
    Something like that. Below are articles on it. So I took the IP and router
    address off the one computer I had the internet working on and
    manually put it on the other–keeping the router number the same
    but changing the IP to .13 at the end. The IP was .1, the router was
    .12. Then I shut off the computers, the router, the modem, and
    turned them all back on in opposite order (modem, etc.) Still same
    problem.

    I’m obviously missing something here. It all used to work fine so I
    don’t know what has happened.

    How do I configure the router? One link said to configure the router to
    act as a “NAT” device so that it will appear that all traffic is coming
    from the router.

    Another person said this: “Who is your internet service provider? I
    know certain ones (including Comcast) require that the router clone
    the MAC address of your computer’s ethernet port in order for the
    router to get an IP address. Most routers have a setting that will let
    you do this.”

    Here’s more about that direction (scroll down a bit):
    http://www.daniweb.com/forums/thread32833-2.html

    So I found this info on how to do this cloning, but I can’t get the IP #
    suggested for Linksys in the browser window to load. Says “page can’t
    be found.”

    I’m not even sure that is the problem, because I can get either
    computer to work through the router, just not at the same time.

    Any advice?

All Answers

  • Author
    Replies
    • #2907866

      Clarifications

      by jay ·

      In reply to Comcast internet and router troubles

      Clarifications

    • #2907864

      Start over again

      by nepenthe0 ·

      In reply to Comcast internet and router troubles

      1) The coaxial cable connects to the cable modem.

      2) Run an Ethernet cable from the modem to your NAT (Network Address Translation) router.

      3) Run an Ethernet cable from the output router port to your desktop computer. You might wish to skip the 1st output port, because it may be assigned a special function (check your router manual carefully for this).

      4) Check the signal strength by hovering the mouse over the wireless network icon in the system tray. Wi-Fi is short range 2.4GHz radio, essentially worthless beyond 150 feet from the access point. Here are some tips that may help reduce dropped connections:

      5) A vertical booster antenna for the router can enhance horizontal coverage by ~50%

      6) If the router is located one floor up or down from the laptop, consider relocating the router to the same floor

      7) If the wireless adapters are 802.11g, program the router to broadcast only in G mode

      8) Enable SSID broadcast in your router setup

      9) WPA encryption is more squirrely than WEP, but WEP is less secure

      10) How important is encryption for you? If there are no likely snoopers within 150 feet, consider disabling encryption. With encryption disabled, connection is faster, data transmission faster, and there are fewer dropped connections

      11) If you disable encryption, it would be wise to enable the MAC address filter in the router setup. Enter the MAC addresses of the wireless adapters, and the native MAC network card addresses of any desktop computers

      12) If you disable encryption and enable MAC address filtration, periodically check for intruders. With Linksys, open the router setup, and navigate:

      Status > Local Network > DHCP Client Table

      The only MAC addresses posted on that table should be your own equipment. Any other MAC address is an intruder, and you can banish that person by adding that MAC address to the naughty list:

      Wireless > Wireless MAC Filter > Prevent PCs listed below from accessing the wireless network

      13) check for 2.4GHz radiofrequency interference near the laptops (cordless telephone base stations)

      14) check for RF interference (fans, motors, hard drives, etc.)

      15) check for shielding (metal cabinets, etc)

      16) If still no connection, try disabling the proprietary driver and enabling the default Windows wireless chip driver.

      17) Configure the router to automatically obtain IP address from DHCP.

      18) Look for a strong signal (>50% signal strength) from a channel close to the router’s assigned channel. There should be 5 channels between such signals to avoid interference due to bandwidth issues. For example, if you see a strong signal broadcast on channel 6, program the router to broadcast on channel 1 or channel 11.

      19) Check your laptop power management. Is there a timeout for the wireless adapter? If so, configure your power management so that the wireless LAN is always enabled and powered.

      20) If you have a proprietary wireless chip driver installed, disable the Windows Wireless Zero Configuration (WZC) service: Control Panel > Administrative Tools > Services > Wireless Zero Configuration [right click > Properties > Disabled].

      21) You may have to do some acrobatics to get everything stable once properly configured. This is the sequence that has worked for me:

      21a) Disconnect the Ethernet cable from the cable modem
      21b) Boot the modem
      21c) Boot the router
      21d) Reconnect the router-modem Ethernet cable

      22) When nothing else works, check the Microsoft Knowledge Base:

      http://tinyurl.com/msqye

      23) When Microsoft can’t fix it, consider Network Magic:

      http://tinyurl.com/66x5cn

      That about exhausts my suggestions. You may legitimately need encryption, but be aware that there is a penalty to pay for the complexities of this technology. If there are no likely snoopers within range of your access point, and you utilize MAC address filtration, and you are not overly concerned about the sensitivity of the wirelessly transmitted communication, your wireless connection will be more predictably successful by disabling encryption.

      • #2907855

        Did the OP say anything about wireless?

        by boxfiddler ·

        In reply to Start over again

        No, of course not. You are making yet another assumption.

    • #2907847

      With just one computer working, is it ok?.

      by Anonymous ·

      In reply to Comcast internet and router troubles

      If all is ok then do an update on all of the routers firmware one by one. Then see if the problems you are having are any less.

      Please post back if you have any more problems or questions.

    • #2907840

      Hi Jay

      by tig2 ·

      In reply to Comcast internet and router troubles

      I also use Comcast so MAY have an idea or two about the problem you are having.

      You say that you are using a Linksys router. How old? I went through two of them and it drove me bats because it would fail suddenly. I replaced the second Linksys with Netgear and have had NO trouble on that front since (been over a year ago). My mother in law had the same issue with hers. When this one dies, we will get her a Netgear also.

      The easy thing to do will be to print this off- it will be long.

      First- unplug EVERYTHING. Your router came with a CD. Feed it to whichever of your Macs you want to configure your device with.

      The install process should walk you through. Protip- when you plug in your modem, let it fully complete it’s boot process. Comcast modems are notorious for wanting to complete the cycle fully. The install disk will want to know what kind of security to use. Use WPA and a complex password string. WRITE IT DOWN, YOU WILL NEED IT. Let the disk guide you through the process of setting everything up.

      Once one computer is online, plug in the second computer. If you are using wireless, the Mac will automatically prompt you for the passphrase. In fact, the Mac should automatically do that on the wired connection as well.

      This should get you up and running again.

      Good Luck!

    • #2913181

      Comcast problems.

      by Anonymous ·

      In reply to Comcast internet and router troubles

      While at home I use Qwest DSL, at the shop I use Comcast Broad band because of the need for greater bandwidth.

      When setting the Comcast modem/router up I ran into a similar problem.

      For reference the work network is something like this Cable -> Comcast/modem-router -> Cisco router -> Cisco router ->>…

      When the network had to be reset due to issues with Comcasts’ line, I found that I had an IP address conflict with each router; they all used the same defaults. Prior to finding this I was on the phone with Comcast and had asked for the default IP of their provided modem/router.

      After much, not needed, speech from them, they finally accidentally provided the information that I needed and initially asked for – the default admin IP/DNS of the router. I laughed for a few minutes, when asked why I was laughing, I told the script reader that this was the information I asked for before his speech.

      To make a long story short; what happened is that the default Comcast admin IP is 10.0.10.1, I set my routers IP’s to non reroutable addresses and the defaults on the Cisco’s also used 10.0.10.z.

      Solution: Unplug cat 5 cables to each router and change the admin IP to a different address, chain the next in and do the same – back up to the Comcast router/modem. Two routers can not share the same DNS.

      Where this is applicable to your situation is in that it may be that when you turn on the two macs, you are having an IP conflict and that you need to change the IP of one of them.

      For the rest of you – sorry about the non-professional writting.

Viewing 4 reply threads