Could not open key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVe

By ing.romi ·
Every time that I want to install a SW, I have this error:

Could not open key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\run.
Verify that you have sufficient access to that key, or contact your support personnel.

I'm an administrador user.

If I go to regedit and search that key, I have this message:

Could not open key.

What can I do? What is wrong?


This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

While you may have Admin rights locally

by HAL 9000 Moderator In reply to Could not open key: HKEY_ ...

The Domain Could be preventing any change so you are unable to add any software to this particular computer. If the problem is that your only alternative is to go to the IT Section and get them to install what you want loaded.


Collapse -

I have admin rights

by ing.romi In reply to While you may have Admin ...

Hello Hal.
This problem, the message Could not..., started one week ago. Before, I didn`t have problems to install programs. But now, when I try to install something, I cannot.
If I go to Regedit and try to open the Key RUN, a error message says: "Error, could not open the key".
By the way, this error is in my personal computer

Collapse -

Well I'm still guessing as you haven't said otherwise

by HAL 9000 Moderator In reply to I have admin rights

But if this computer is on a Domain it could be preventing you from installing any software by a new setting in AD or a New Rule imposed in the Group Policies. This is actually quite easy to do to prevent end users from installing software unauthorised by the company. This may continue even when the unit is disconnected from the Domain depending on what has been done by the System Admin to keep the Network Secure. Admin Rights at the workstation would effectively only give you the ability to run things like Defrag which isn't possible in the Restricted User Mode. So you could run the routine Maintenance Tasks buy not be allowed to install any new software. Things like this are quite often brought about by people abusing the trust that has been placed in them so a couple of people ruin things for everyone else. If you are part of a big company or even a decent sized Domain it's possible that someone installed some software that compromised the Networks Security and the system Admin to prevent this from happening again has introduced some rule to prevent anyone but the IT Department from installing software.

However if this is a Stand alone computer that's a totally different story.


Collapse -

Could not open key

by jacquesj9 In reply to Well I'm still guessing a ...

This is one solution to the problem. A 2005 article called this "brute force".
I got the error message "Could not open key" the error said I did not have permission (even though I have administrator privileges). I got the same exact error when trying to install an adobe acrobat update.
With REGEDIT.exe, go to HKLM\software\microsoft\windows\currentversion\sharedDLLs. Right click on the key and chose permissions. On the Group or User Names section, hit the Add button and type EVERYONE, check the Full_Control and Read boxes and OK. You now have permission.

Collapse -

It Worked!!!

by spchiniquy In reply to Could not open key

I have been trying everything to figure out how to fix this problem, dozens of websites (including Microsoft's), tech support, etc., and nothing worked until I read your post. THANK YOU!!!!

Collapse -

Just like files and folders, the registry can be locked down with ACLs'

by ManiacMan In reply to Could not open key

That's the problem that was encountered here. This can also be done through a group policy object that was misapplied or incorrectly configured.

Collapse -

"IF" it's your personal machine, Start up in safe mode. .

by Keith Hailey In reply to Could not open key: HKEY_ ...

Then log in as administrator and see if that doesn't work with regedit. Worth a shot

Collapse -

Same Problem - Can not log on as Administrator

by tae.chang In reply to "IF" it's your personal m ...

I get this same exact problem. I just bought this computer (Windows XP Home) and I created 2 user accounts. At the Welcome screen, I hit ctrl+alt+del and type Administrator to log in but none of my passwords work?

Since I never did anything but add another user, I don't even know what the default password would be.

Very frustrating because I can't install software or even upgrade software (iTunes) because of this error.

Collapse -

Normal for XP Home

by IC-IT In reply to Same Problem - Can not lo ...

You can not logon to XP Home with the default admin account except for Safe mode.
You can right click an exe file and Runas Admin.
You may want to create an additional account with admin rights. You can than logon with the new account.

Back to Software Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums