General discussion

Locked

Damaged AD DNS

By Paradox 42 ·
Ok I am upgrading an NT 4 domain to 2000 and had some problems with hardware on 1 of the servers. After upgrading this server and installing all the windows updates etc I decided to dcpromo it into AD. But the server died half way through the install. This has done something to my DNS on my fist 2000 AD server and I can't get it to work. I have tried uninstalling and reinstalling the DNS and reconfiguring it from scratch, but nothing seems to work. The doggy server has had the hardware replaced and was reinstalled to 2000 and dcpromo'ed on to the AD but wont run DNS properly and wont replicate any of the AD. If anyone can help, I would be very grateful.

Server 1: arc20840099 ? first AD 2000 server. Running DNS, DHCP, WINS

Server 2: cdserver - second AD 2000 server. Running nothing but dcpromo?ed to the first server. Also wont run DNS properly when installed (was trying to use it as a replacement DNS)

All server point to arc20840099 for DNS and WINS both servers have static IP?s

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Paradox 42 In reply to Damaged AD DNS

netdiag has this to say about DNS:
----------------
DNS test . . . . . . . . . . . . . : Failed
[WARNING] Cannot find a primary authoritative DNS server for the name
'arc20840099.arc2084.'. [RCODE_SERVER_FAILURE]
The name 'arc20840099.arc2084.' may not be registered in DNS.
[WARNING] The DNS entries for this DC are not registered correctly on DNS server '10.84.38.2'. Please wait for 30 minutes for DNS server replication.
[FATAL] No DNS servers have the DNS records for this DC registered.
-----------------
this was from arc20840099 to itself

Collapse -

by Paradox 42 In reply to Damaged AD DNS

also the DNS entry for arc2084 dosn't have any of the AD stuff it should have. the forward lookup of arc2084 is AD intergrated.

Collapse -

by Arne.Tredal In reply to Damaged AD DNS

Have you tried running NetDiag with the /FIX option? This has helped me out a couple of times.

Collapse -

by Paradox 42 In reply to

Thanks for replying. I found out what was wrong and fixed it my self soon after posting the question. I had a non-standard domain name (ARC2084 not ARC2084.com) and this was stopping the DNS from /fix'ing. mod'ed the reg as per the Microsoft KB pages instructions and run NetDiag /fix. All working fine now.

Collapse -

by Joseph Moore In reply to Damaged AD DNS

You are probably missing some DNS records that AD usually makes during the DCPROMO process. There are more than just the SOA and A records for AD to work in DNS.
There are _udp.DNSDomainName, _tcp.DNSDomainName, _sites.DNSDomainName, and _msdcs.DNSDomainName records.
All of these need to be in DNS for AD to work, pointing to your Domain Controllers.

Try reading this Technet article:
http://support.microsoft.com/?kbid=255913

It tells you how to manually set up DNS to work with AD. I would use this one to set up the DNS on your AD box.

hope this helps

Collapse -

by Paradox 42 In reply to Damaged AD DNS

This question was closed by the author

Back to Windows Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums