Question

Locked

Desktop Shortcut Icons changed to undefined icon

By Hypatia ·
It didn't happen all at once - slowly over time my desktop shortcut icons to both Internet URLs and Network shared drives have changed from the custom icon I had, to the icon that represents an "undefined" file. This only occurs when I have the icons set to "large" (Display Properties \ Appearance \ Effects \ Large Icons). As soon as I change the settings back to default size - I get the icons back. I am using IE7 and WinXP.

I have tried everything from TweakUI, to changing Registry settings for Max Icon Cache, to having my network guy change my profile name so I could log-in and create a new profile. My Network guru thinks it might have to do with IE7 as the network has recently forced that upgrade to all workstations.

Anybody else experienced this? Did you find a fix?

Thanks for your time & help.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Large size custom icon not installed

by nepenthe0 In reply to Desktop Shortcut Icons ch ...

When you select large icon size, Windows will search for the customized icon, but if the only available icon is small, Windows will substitute a generic default icon.

Icons come in 4 sizes:

32x32 pixels
48x48 pixels
64x64 pixels
72x72 pixels

I suspect that your large icon is 48x48 pixels, but you should check this to confirm. One way to do that is to open a large icon with Microsoft Paint, or simply right click and select Properties.

The solution, if you prefer large icons, is to configure a customized large icon. This can be done with the default Paint application, or you may wish to obtain a more sophisticated program such as Microangelo:

http://www.microangelo.us/

Also, check out LiquidView:

http://tinyurl.com/3kdde3

Collapse -

Large Icons

by Hypatia In reply to Large size custom icon no ...

nepenthe...
I have icons from 32 to 96 available - none are working.

Collapse -

See if this works for your icons.

Increasing the Folder Cache
The default setting for WindowsXP is to cache the Explorer settings for 400 folders.
To increase it:
1.Start Regedit
2.Go to HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam
3.Change the vaule of BagMRU to whatever size you want (hex)
1000 - 3e8
2000 - 7d0
3000 - bb8
4000 - fa0
5000 - 1388

Please post back if you have any more problems or questions.

Collapse -

Folder Cache

by Hypatia In reply to See if this works for you ...

Thanks for the idea, Peconet, but my MagMRU is already set to the 5000 (138 value.

Collapse -

More info on Icons here.......

http://vlaurie.com/computers2/Articles/icons.htm

Please post back if you have any more problems or questions.

Back to Software Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums