General discussion

Locked

Dual network card problem with RH6.1

By indyz ·
I have a P100 with 32MB RAM, a NE2000 ISA network card, a 3Com 3C509 ISA network card. When I try to initialize the the network, the first card loads, but the second fails with this message...eth1 delaying intialization...I checked dmesg and the syslogs. They show only one card...(makes no difference, which one I select...the other never initializes).

Any suggestions?

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Dual network card problem with RH6.1

by dtortorich In reply to Dual network card problem ...

I have several of these cards..the 3C509's. They work great but require a little setup. They all ship withe the exact same configuration...same IRQ, same Base address, etc., flashed into the EEPROM bios on the card. What is happening is that one card is intalizing and then blocking the 2nd from coming up.


What you need to do is to download the drivers (for DOS) that came with this card. There is a configuration utility that comes with the drivers that will allow you to change the IRQ and base adress of the 2nd card so that you won't have conflicts.

So go to DRiversguide.com and look for those drivers. Then use an old DOS boot diskette (a windows boot diskette would probably work too) to get your linux box to boot into DOS. Then run the little .bat config program and re-flash that EEPROM bios.

The next time you boot into Linux it should find both cards.

E-mail if you have probs.

Ctorto1@hotmail.com

I have the driver if you get in a pinch.

Collapse -

Dual network card problem with RH6.1

by indyz In reply to Dual network card problem ...

Thank you that was part of the problem...It helped.

Collapse -

Dual network card problem with RH6.1

by jdixon In reply to Dual network card problem ...

I ran into the same problem setting up a firewall with RH 6.1 a while back, with the same cards, well actualy the the ne2000 was a ne2000 compatible. The machine was a 486 120mhz. Anyway, the only solution I arrived at was buying another 3com to putin.I went ahead and reinstalled leaving one card in and then adding the secon card later, and that did the trick. Hope this helps.

Collapse -

Dual network card problem with RH6.1

by indyz In reply to Dual network card problem ...

Thank you! That was also a good answer...if something does not work, get something that will. 3Com rules!!

Collapse -

Dual network card problem with RH6.1

by crle In reply to Dual network card problem ...

I have had a similar problem with my system, which has 2 NE2000 cards. The first thing to check is the conf.modules which is in /etc. It probably looks something like this:

options eth0 io=0x320 irq=11
alias eth0 ne
options eth1 io=0x260 irq=10
alias eth1 3c90x

Now modify your conf.modules to look like this (of course with your own card settings):

options ne io=0x320 irq=11
options 3c90x io=0x260 irq=10
alias eth0 ne
alias eth1 3c90x

Hope this helps. There isn't a whole lot of difference, but it worked for me.

Charles

Collapse -

Dual network card problem with RH6.1

by indyz In reply to Dual network card problem ...

Poster rated this answer

Collapse -

Dual network card problem with RH6.1

by Victor_F In reply to Dual network card problem ...

1st make sure your kernel has network device support enabled for both 3c50x and ne2000.
You need to find out which IO/IRQ your 2 cards are using by checking them with their own DOS based diag utility and make sure they are not using conflicting IO base or IRQ addresses.
Then, add a line like this to your /etc/lilo.conf
append = "ether=10,0x320,eth0 ether=11,0x340,eth1"
the first argument 10 is the 1st NIC IRQ the 0x320 is the 1st NIC IO Addr. and so on.
Don't forget to activate changes by running /sbin/lilo.

I have a box configured as a router/firewall with 8 Network cards.

Collapse -

Dual network card problem with RH6.1

by indyz In reply to Dual network card problem ...

Poster rated this answer

Collapse -

Dual network card problem with RH6.1

by indyz In reply to Dual network card problem ...

This question was closed by the author

Back to Linux Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums