Excel 2007 - "open with" command does NOT list Excel

By mfhawn ·
I use Excel to edit various types of files, such as IIF (QuickBooks list
files). I used to be able to right-click on the file and choose Open With
and then Excel was listed. Recently, I noticed that Excel is not listed and
so I have to browse through the programs menu, and then, even when I choose
excel, it doesn't open. It seems trivial, I know, but I want it to work the
way it used to work!

I ran office diagnostics and it didn't find anything. Any ideas other than
reinstall, because I don't want to deal with that.

I tried to change the file associations for the various files I try to edit, but I CANNOT choose Excel. I can browse to find it, because it is not in the list of programs, and once I do find it, and click on it, it doesn't accept it. It just acts like I've done nothing.

Any ideas? I don't want to reinstall. I don't have that kind of time!

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Re. "open with" command does NOT list Excel

Go to "open with" then either "browse" or "Choose Default Program", from here you will be able to select/choose which program opens the file(s) after this you can make this the default program to open file(s) of this type.
Hope this helps you.

Please post back if you have anymore problems or questions.

Collapse -

Still doesn't work

by mfhawn In reply to Re. "open with" command d ...

I did exactly that, but when I browse and choose excel, it doesn't keep the selection. It returns me to the previous window without excel in the list. That's what is so frustrating - I know what to do but it won't let me! And it's only Excel. Word, PP, the rest of them work fine that way.

Collapse -

Try it this way

by IC-IT In reply to Excel 2007 - "open with" ...

Open Excel first.
Use File - Open.
In the type of files change it to all file types.
Navigate to the file you want and select Open.
After opening close Excel, then try the right-click. Excel should be back in the Open With.

Collapse -

Still doesn't work

by mfhawn In reply to Try it this way

Well, I opened it that way. However, it STILL won't let me do it. I'm going to just uninstall and reinstall.

Thanks for all the help.

Related Discussions

Related Forums