General discussion

Locked

Exch5.5 - major dramas

By sake ·
Hi all,

My Exchange 5.5 server today completely baffled me when it began spitting the following error into the App log on Win2k server (9 times per second):

Source: ESE97
Categ: Performance
Evt I 0
Desc: MSExchangeIS (2580) Unexpected NT API error:0xC0000054

I rebooted it and saw that it needed to initiate extensive recovery steps from a huge number of log files, as well as finding loads of files in a spool directory but not in the delivery queue.

After the server was in a settled state (I had to start the IMC and Event Service manually), I again rebooted and got a clean boot.

I can find no info on the meaning of the above error. Can anybody shed some light?

Thanks,

Sake

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by osilaya In reply to Exch5.5 - major dramas

It appears that the information store on your exchange server seems to be having some issues. You can start by setting the logging on the information store to maximum and then take a look at the application log file on the server the next time you get this message.
ESE97 is the database engine of exchange 5.5 and is what handles transactions before they are commited it also handles automatic recovery during startup and rolls back any uncommitted transactions. I'm guessing that something has caused the information store to crash in the middle of a transaction but what exactly caused it we'll have to wait and see from the logs.
Make sure you only change the logging for IS temporarily as keeping it on max permanently can impact the performance of your server.

Collapse -

by sake In reply to Exch5.5 - major dramas

Thanks for your response osilaya. Since my post, I've received the following (after a reboot):
Source: ESE97
Categ: Logging/Recovery
Evt I 0
Desc: MSExchangeIS (2668)-1022

Then;
Source: MSExchangeIS
Categ: General
Evt I 1120
Desc: Error Disk IO error initializing the MS Exchange Information Store database.

Then;
Source: MSExchangeIS
Categ: General
Evt I 5000
Desc: Unable to initialize the MS Exchange Information Store service. Error Disk IO error.

Then (sorry);
Source: ESE97
Categ: Performance
Evt I 0
Desc: MSExchangeIS (268 Unexpected Win32 error: 0x21

Finally repeating;
Source: MSExchangeIS
Categ: General
Evt I 1159
Desc: Database error Disk IO error occurred in function JTAB_BASE::EcSetColumn while accessing the database.

Now I know what you're thinking - DiskIO is the problem. Well I contacted HP support and we went through the System Log, the IMLs and the ACU and they insist that there is nothing wrong with those drives and definitely nothing that would justify a replacement. The logical drive in question, is actually 3 physical drives in a RAID5 array within an external SAN drive enclosure (with 9 other physical drives). The only difference I could find, was that under the Insight Management Web Interface, ONE drive in the enclosure registered 7 under "Other Timeouts" in the "Problem Indicators" section. This however doesn't yield much because the recommended tests are very generic (ensure cables plugged in, etc). I was wondering, is it possible that something is wrong at the Windows (2K) or even Exchange (database) level? Is it possible that the physical hardware is operating properly, but being incorrectly blamed by the OS or Exchange?

What other steps can I take to investigate? In the meantime, I'll swap the drive with the 7 "other timeouts" with a different drive in another slot. This may eliminate the drive or the slot from the list of possibilities.

Thanks again for your help!

sake

Back to Software Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums