Question

Locked

External hard drive cannot be accessed and not responding

By klsleon ·
i have a 1TB western digital hard drive. when i plug it in it only shows local disk (G: ) and will keep on loading even when i clicked it. i tried running diskmgmt.msc and it successfully open and shows all the storage but it hangs up and stops responding if my hard drive is plugged in. sometimes it stops at "connecting to virtual disk service or loading disk configuration information". what should i do? please help. all my school files and other important data are inside my hard drive

This conversation is currently closed to new comments.

1 total post (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

You have 3 options

by jqbecker In reply to External hard drive canno ...

1. Call WD. If under warranty they can help.

2, Might be the ext hard disk case or power adapter:
-there is a small circuit board inside the WD case, that may be the issue.
-get a new external case, they are cheap $30 or less
-move the disk out of WD case to new case.

3. If disk is still not recognized:
-buy a cheap disk recovery software like Disk Scavenger, only $30 or so.

Back to Windows Forum
1 total post (Page 1 of 1)  

Related Forums