Installation package could not be opened. Verify...

By fishe1 ·
I am getting this error message when trying to install various apps... "Installation package could not be opened. Verify that the package exists and that you can access it, or contact vendor to verify that this is a valid Windows Installer package."
I just got a new machine (new to me) Mainboard : Unspecified 8363-686A, Chipset : VIA KT133A , Processor : AMD Duron @ 900 MHz, Operating System : Microsoft Windows XP Professional 5.01.2600 Service Pack 2, however I was having the same problem with my other machine as well (asus board with intel PIII). I cannot install Java, Adobe, or even Windows Live Messenger, and this is on a fresh install. I found where it might be a bad Msi.dll file from the SP2 update, but don't know how to fix it. Does anyone know of a work around or what is locking me out? HELP!

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Having recently completed a fresh install ...

by OldER Mycroft In reply to Installation package coul ...

You should be aware that AFTER you install Service Pack 2, there still remains some 125MB of updates to bring your system to current update status.

It surprised me just last week.

Have you installed all the 125MB of other updates yet?

Collapse -

Have all Updates

by fishe1 In reply to Having recently completed ...

Thanks for the reply. I have all available updates, and Automatic Updates is on and working properly.

Collapse -

A Few Observations

by tintoman In reply to Installation package coul ...

Firstly if you are sure that you have a corrupt, damaged or missing .dll file these are fairly readily available for free download from the net, I have used and got myself out of trouble several times.
The problem you describe also seems to indicate that you might need to be a system administrator to run certain applications, I would suggest you try to right click the .exe file and select "run as" and select administrator and put the admin password in if you have one.
Also it might be the case that the windows installer is not installed, you should make sure that you have all your microsoft updates installed, if automatic updates are not functioning properly you could try downloading dial-a-fix from I have found this to be excellent at repairing many faults.
Hope that was a help good luck

Collapse -


by fishe1 In reply to A Few Observations

Thanks for the reply. I tried the "run as"... didn't help, have Windows Installer 3.1, and updates are on and functioning. I will try replacing the .dll. I assume I delete the file in question then paste in the new one?

Collapse -

Nearly done

by Jacky Howe In reply to Done

Delete the old file and replace it with the new one and try this.

Click on the Start button, then click on Run
In the "Open" box, type the following

regsvr32 Msi.dll

This should reload the dll.

Collapse -

Not Nearly

by fishe1 In reply to Nearly done

Thanks for the reply. I don't think that dll file was the problem. Though I did have the old Msi.dll file in a couple places, replacing it did not correct my install issues. The problem first occurred 6 to 9 months ago with the previous XP pro install. I'm thinking a windows security update triggered it. I may start over clean with a new install of XP, then try to load all my applications before the SP2 patch. At least my new(new to me) computer is faster than my first one. I will still follow this thread for more suggestions.

Collapse -

I am curious

by Jacky Howe In reply to Not Nearly

what are you trying to install? Are you logged on as an Administrator?

Edit: forgot to add this.
Edit: Posted wrong info
MSI Error 1619
Often this error is seen as a result of insufficient access to the installation folder.

Collapse -


by fishe1 In reply to I am curious

Thanks for your help.
Attempting to install Java from, I get a 1324 error "the path Documents and Settings contains an invalid character" followed by a 2707 internal error, and offline install brings up the original error message that I get when trying to install Adobe reader, Windows live messenger, and some others. Eccept for the Java, it doesn't matter if The files are online or saved to various locations on my computer. The windows installer will initiate and then cick it out along with the message that began this thread. Blue Soleil, a bluetooth app. I use is another one that is doing this.
As for a 1619 error, I don't know. I haven't seen that number with this error. I did however verify that I am signed in as admin with full permissions and access.
As stated before, I believe something changed months ago, prior to my new computer, prior to this new istall of XP pro. I play with a lot of software, and install and uninstall software on a daily basis. I ran my very first windows XP pro install ever for over a year with almost no problems. I had also ran the my next fresh install of XP for some time before I began encountering this error. I fixed the Msi.dll files in question that came with SP2 but still think the problem lies in a service pack update. I believe I was able to fix this problem once months ago by reinstalling widows installer 3.1, but that fix doesn't work now and more apps get kicked out now then when the problem first started.

Collapse -

Ok one more

by Jacky Howe In reply to WHERE TO START

Create another User Account with Administrative privelages and see if that will let you install. That wat we will see if it is a corrupt user account.

Collapse -

I think you need to start right here......

by ThumbsUp2 In reply to WHERE TO START

You said: "the path Documents and Settings contains an invalid character" followed by a 2707 internal error

According to Microsoft, error 2707 means:

Target paths not created. No path exists for entry [2] in Directory table.

So that, combined with the error saying "the path Documents and Settings contains an invalid character", I think your problem is self explanitory. Either the directory structure on the hard drive is corrupt, or you've somehow disabled the long file name feature.

The following article says it's for Office 2000 and Windows 2000, but the instructions on where the registry key is located remains the same for XP. If either Win31FileSystem or NtfsDisable8dot3NameCreation entries are set to some value other than 0 (zero), you'll get the error you've mentioned.

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs.

<edited to add MS article found>

Related Discussions

Related Forums