General discussion

Locked

Microsoft Access can't load 'rd' format

By dfornet ·
When I launch Access 97, I get the following message "Microsoft Access can't load 'rd' format. The setting for this format in the windows registry is incorrect"

This when launching a shortcut pointing to a db on a lan share, but nobody else is having this issue, only one user.

No indication is given as to the registry key in question. I have completely uninstalled, rebooted and reinstalled Access. I have taken the registry hive for Access from a known good machine and applied to this one, but still no good.

Help!

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by DugaDugDug In reply to Microsoft Access can't lo ...

You mentioned you reinstalled Access but did you also reinstall all applicable patches for Office 97 and/or Access 97? e.g. Sp2?

http://office.microsoft.com/en-us/officeupdate/CD010699651033.aspx

Collapse -

by dfornet In reply to Microsoft Access can't lo ...

Yes, SP2 has been applied. This is only happening with one user, while I have several more with the same setup that are working like a charm!

I know that it is profile related, but I hate to just give up and rebuild the profile.

Collapse -

by denovo In reply to Microsoft Access can't lo ...

I had similar (not 'rd' but different depending on the table I was opening) happening just earlier today with an Access97 install on XP. Then when I was looking at Export, various file type options were missing. Research led me to the actions below, which have cured both problems - try it.

Try re-registering the dll files like this:
Start Run
regsvr32 msexcl35.dll
regsvr32 msxbse35.dll
regsvr32 mspdox35.dll
regsvr32 mstext35.dll

I had earlier used the following link to update / correct the OS files as Access had previously given an Out Of Memory error when I tried to open it.
http://www.randem.com/support.html#Automatic%20Installation

Collapse -

by denovo In reply to

Oh no - sorry I am wrong, the problem you speak of is not cured, my mistake.

Collapse -

by denovo In reply to

Hey, now it is fine. I had previously checked the 98/ME compatibility mode for the program when I had 'Out Of Memory' error messages on trying to run it, prior to correcting the system files (as in the link above.)

Now I have unchecked the compatibility mode (on the Compatibility tab of the properties sheet for the Access executable) everything is fine - no more "can't load 'xxx' format" errors.

Back to Software Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums