General discussion

Locked

MSExchangeIS error

By jcetoute ·
My W2K Xchnge server is a member server with SP3. The application event log is full of warnings about MSExchangeIS, event ID 9543 with error messages such as: Unable to create Public Folder proxy object for "all public folders" in Active Directory.
To go with that I'm also getting a lot of W3SVC warnings in my system event log viewer, with the same error about "The server was unable to logon the windows NT account 'IUSR-SERVERNAME' due to the following error: The referenced account is lockedout and may not be logged on to. The data is the error code."

Any help is appreciated.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Here is some info....

by Amadeus Hack In reply to MSExchangeIS error

First off go to http://www.eventid.net at the top of the page click "search events" you can enter the event id and it will give you some info, but here is what I found....

A public folder's rights became corrupted. The Public Folder (Alerts) was deleted and then recreated. After the object was recreated the mail properties were unavailable and this error started showing up in the event log. There was an instance of the Alerts in the Public Folder Instances in the First Storage Group that didnot have a Folder Path association. I could not remove this object using EXSM. I fixed the AD record as follows.
1. Deleted the public folder.
2. Opened ASDI editor from the Windows 2000 Resource tools and found the AD object of the Public Folder.(LDAP://ad01.jaytown.org/CN=Alerts,CN=Microsoft Exchange System Objects,DC=jaytown,DC=org) Took ownership of the object in AD and then deleted the object.
3. After the object was deleted a new folder (Alerts) was created and this object?s Mail properties were accessible. The content of the original folder was restored and the rights were recreated.

See next post....

Collapse -

Next.....

by Amadeus Hack In reply to MSExchangeIS error

Apply the latest Exchange Service Pack. From a newsgroup post: "When a public folder is mail enabled, the Web Storage System needs to create an object in Active Directory for that folder. Usually this message indicates a permissions error in ActiveDirectory. Review the Event Viewer for messages from the system attendant."
Also from newsgroup posts: "If you try to pull up properties on the PF objects in ESM, do you get this error: The mail proxy for this folder can not be found. This may be due to replication delays. The mail enabled pages will not be shown. ID no: C1038a21 If so, are you running Win2k SP2? There was a fix for a problem that sounds a lot like this included in Win2k SP2. Alternately, ensure that your computer account is a member of the "Exchange Domain Servers" group in the Users container. In order for the RUS to process objects such as these PFs successfully, your computer account must be a member of this group, and the permissions for this group must be applied throughout the AD."

As per Q309793: "This behavior can occur if the display name of a public folder is longer than 255 characters. The system attendant can neither create a public folder proxy object nor truncate the name.". The article confirms that this is an issue with Exchange 2000.

Q318552 specifies that "These errors can occur when there is a disjoint namespace, where one or more child domains are not under the root domain in the forest.". The latest Exchange service pack should solve the issue.

From Q278441: "This problem can occur if the public folder has not been stamped with a proxy address (for example, pubfolder@ domain.com).". The Q article provides the workaround.

See Next Post....

Collapse -

Last One....

by Amadeus Hack In reply to MSExchangeIS error

Tip #3 below fixed the problem for me. I don't know how the Remote Registry Service is tied into AD or E2k, or how it was set to manual, but starting the service and unmounting/remounting the public folders fixed a week long problem:
This problem can occur if the public folder has not been stamped with a proxy address (for example, pubfolder@<domain>.com). Here are some possible solutions:
1. Stop and restart each of the Exchange 2000 services. Restart the server. > Run Exchange 2000 Setup again with the /DomainPrep switch.
2. Apply Service Pack 2 for Exchange
3. Check to see that the Remote Registry Service is running on the Exchange 2000 server.
4. Rerun setup with /reinstall switch. Reapply latest service pack.
5. Reboot if prompted.

Tom Korb
If the System Attendant service is started with an account other than the Local System account this can be the cause of event ID 9543. This event is generated when the Recipient Update Service cannot stamp email addresses on public/system folders. To resolve this issue, start the System Attendant service using the Local System account and rebuild/update the Recipient Update Service.

I hope this helps!!!! Good Luck!!!!

Back to IT Employment Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums