My Acer laptop freezes at start-up and won't load any further! HELP anyone!

By synnx47 ·
So I turned on my Acer laptop and it froze. It only showed "Intel Acer" loading screen and it loaded a little bit, but not till the end and there it stuck FOREVER. I tried pressing some buttons, but after I pressed a couple of them it started beeping every time i press the button. Yeah I tried to turn it off and on and all that, I even opened it up to see if everything ok and it seems ok. It didn't even go to the Windows loading screen, it stuck at "brand loading screen, intel acer"... I pressed ESC and then the black screen appeared with the system info, and it also got stuck there. Then i pressed the F2 button, it says "Entering SETUP" and there it stuck as well. So it won't pass the brand loading screen, it won't enter the Setup menu OR Boot menu, NOTHING at all, it just stuck there every single time i try. If anyone of you may know the solution or the problem that is causing this, please reply ASAP. Thanks.
Here's some info:
Acer Aspire 5630 series
Model NO: BL50
DC rating: 19V, 4,74A
Windows 7

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Share your knowledge

Related Discussions

Related Forums