General discussion

  • Creator
    Topic
  • #2093247

    My Windows 98 Swap File is Hugh

    Locked

    by richv

    I noticed last night that my win386.swp file is 811,xxxK which is about 800MB. How do I reduce its size?

    I checked Microsoft’s knowledge base and all I can find is an article that says Win98 does not reduce the swap file to 0 bytes at shutdown bydesign.

    Thanks for any info you can provide.

    -Rich
    richv@drexel.edu

All Comments

  • Author
    Replies
    • #3869434

      Re: My Windows 98 Swap File is Huge

      by rhythm12

      In reply to My Windows 98 Swap File is Hugh

      You will need to set your virtual memory to a specific size limit temporarily. I recommend that you take the opportunity to also defragment your hard drive during the procedure.

      Start by:

      If this is a critical system and/or has less than 32mbof RAM- perform a backup or skip the next two steps!

      Under System Properties (right click My Computer and choose properties or System in Control Panel), Select the Peformance tab and click the Virtual Memory Button. Change the option to “Let me specify my own…” and disable virtual memory. (Please NOTE: Win9x has been known to operate unstable and slowly with no Virtual Memory) Select Ok and restart the machine when prompted.

      When it restarts and the hourglasses are gone run Defrag (aka: Disk Defragmenter). Defrag the C: Drive.

      Once Defrag has completed, go back to System Properties and uncheck “Disable Virtual Memory” and set both your virtual memory startup and maximum to atleast double the physical memory. If the system isused to work with large files or documents (ie: graphic or audio editors) you should factor even higher. [Note: by setting the startup and maximum size equally you force Windows to limit fragmenting the swap file while windows is running; if the swap file is larger than any contigous free space it will be fragmented but it will not fragment beyond that. The swap file is the most important and heavily used file to windows once physical memory has been allocated, as such if its fragmented the system will perform slower.]
      Click OK and restart the system when prompted.

      Sean

    • #3869375

      RE: Swap File Too Huge

      by thmiuatga

      In reply to My Windows 98 Swap File is Hugh

      Rich;
      I’m checking my references to your dilemma right now. I am consulting my “Mastering Windows 98” book and the “PC upgrade and repair bible”. from what I’m making of it you’ll have to set the “windows Virtual Memory” in the performance tab of the My Computer section. I got this from the PC bible as opposed to the Win98 book. also the other choices are adding more system memory and/or getting a faster hard drive.
      I hope this helps you.

    • #3869290

      there is a way

      by nikolas

      In reply to My Windows 98 Swap File is Hugh

      You can reduce the swap file by doing the following steps: right-click on My computer -> properties–> performance–> virtual memory–> let me specify my own memory settings –> set minimum to at least 20Mb and maximum not more than 20% of free HDD space.
      Then click OK no matter than Windows will tell you that it’s not good 馃檪
      Reboot and enjoy 馃檪

      • #3869193

        Win9X Swap File Help

        by itsmike29

        In reply to there is a way

        I have found that forcing WIN9X to use a swap file size that I tell it has solved a lot of little knick-knack errors. The first reply to this post was right on the money.

        Here is that reply with my addition:

        Under System Properties (right click My Computer and choose properties or System in Control Panel), Select the Peformance tab and click the Virtual Memory Button. Change the option to “Let me specify my own…” and disable virtual memory. (Please NOTE: Win9x has been known to operate unstable and slowly with no Virtual Memory) Select Ok and restart the machine when prompted.

        When it restarts and the hourglasses are gone run Defrag (aka: Disk Defragmenter). Defrag the C: Drive. IT ALSO WOUDLNT HURT HERE TO RUN A THOROUGH SCANDISK PRIOR TO RUNNING THE DEFRAG.

        Once Defrag has completed, go back to System Properties and uncheck “Disable Virtual Memory” and set both your virtual memory startup and maximum to atleast double the physical memory. IT IS IMPERATIVE THAT YOUSET THESE NUMBERS TO BE THE SAME NUMBER!!! I TRY TO GO AT MINIMUM 2X RAM or 4X RAM IF THE HDD HAS ENOUGH SPACE. BY SETTING THESE NUMBER TO BE THE SAME SIZE, YOU DONT GIVE WINDOWS AN OPPORTUNITY TO “PLAY” WITH THE SIZE OF YOUR SWAP FILE.

        Good luck. I hope this helps. Anyone please feel free to email me if you feel I have provided wrong or unhelpul information.

        Thanks

        Mike
        itsmike29@yahoo.com

    • #3639104

      Swapfile blues

      by matrix007

      In reply to My Windows 98 Swap File is Hugh

      Don’t let windows run your swapfile. go to system – properties – virtual memory. choose which partition, formula is ram*2=swpfile or people say ram*2+128=swpfile. set for min and max. if the system seems slow you may need more memory or not to run many programs at once.

Viewing 3 reply threads