General discussion

Locked

No modem!

By vanster169 ·
I just installed Mandrake 7.1 with the PPP service. I set up pppd, but it tells me the modem is busy when I try to dial. I'm using an external modem on the first serial port (cua0/ttyS0) but I never see any lights toggle, even when booting into Linux. The same hardware multi-boots into WIN95 and
NT 4.0 and I can use the modem with no problems. Running one of the hardware scanners under Gnome or KDE shows no modem installed.
What's next?

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

No modem!

by ddiall In reply to No modem!

Check your /var/lock directory for a file named like 'LCK..ttyS0'. If there is one, read the pid number inside it, maybe the program running with that pid is locking the modem...

As 'root', run 'minicom -s', select the apropriate options and then, in terminal mode, try giving some AT commands.

Finally, it might happen that your serial ports are not being well recognized.

Collapse -

No modem!

by vanster169 In reply to No modem!

I didn't really help me, but since you're the only one who answered in a week, I'll give ya the points.
I don't have a minicom installed, and there are no lock files for program IDs running.
the hardware is a standard 16550 UART, Linux shouldn't have a problem with that...

Collapse -

No modem!

by vanster169 In reply to No modem!

This question was closed by the author

Back to Linux Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums