General discussion

Locked

NT SAM access denied issues NDS for NT

By Hector Ramos ·
Our Netware admin just uninstalled NDS for NT from our NT DCs. The NT SAM will not longer allow creation of new objects. Existing ones can be modified, passwords updated and such; but nothing new. The problem manifested itself when a workstation lost the trust relationship with the domain. We removed it from the domain and tried to re-add it. It gave us an error like it thinks the drives on the PDC are full and the SAM cannot be updated. There is plenty of room available to the registry and everything else. I suspect that the problem is tied to the automatic periodic renewal of the domain SID. If this is the issue, we have a time-bomb in our hands. We tried re-applying SP6a to get the newest SAMSVR.DLL a file modified by NDS for NT. The SAM remains locked to us. My next step is to try to promote the BDC to PDC and see if it's SAM will allow us to write to it. If that fails, things get ugly quickly. Help?!?

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

NT SAM access denied issues NDS for NT

by macosta In reply to NT SAM access denied issu ...

so, can you give me the event I for this error.

I had the same problem but with w2k server, I've been finding the solution and found that my hard disk was failing, so this was the problem.

Collapse -

NT SAM access denied issues NDS for NT

by Hector Ramos In reply to NT SAM access denied issu ...

Well, we have it going. We had to change the rights to the HKLM\SAM\SAM key and subkeys, in the PDC from Special Access to Full Control. I'm leaving this question open; because, I know this is nothing but a band-aid. I'd still like to find a better fix.

Back to Windows Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums