• Creator
  • #2220973

    office 2007 spell check inop


    by mbwmn ·

    i recently upgraded a desktop from Office2003 to 2007. the user no longer has spell check functioning in Word and Outlook. if you press the “abc” button it says spellchecker has run, but it does not flag obvious mistakes.

    if i log on as a different user spell check functions correctly.

    any suggestions, other than blowing out the user profile? so far i have “repaired” and re-installed the Office 2007 suite.

All Answers

  • Author
    • #2550367


      by mbwmn ·

      In reply to office 2007 spell check inop


    • #2550363

      Office 2007 Spell check issue….

      by Anonymous ·

      In reply to office 2007 spell check inop

      Copied from:

      If you are facing an issue where you?re using Microsoft Office Word 2007 and the Spellcheck feature is not working while you are typing or even when you click on ?Check Spelling and Grammar? it doesn?t detect any mistakes, here is the possible solution for you to fix that issue.

      * Open Microsoft Office Word 2007
      * Click on the Microsoft Office logo on the top left of the screen.
      * Click on Word Options
      * Click on Popular at the left hand side Pane
      * Click on Language Settings at the bottom
      * On the left hand side under ?Available editing languages?, look for English (Australia) then click Add
      * At the bottom where ?Primary Editing Language? change it to English (Australia) at the drop down menu
      * On the right hand side under ?Enabled editing languages?, highlight any other language other than English (Australia) then click Remove in the middle.
      * Click on OK
      * Click on OK again
      * Restart the whole computer

      Now test the issue and see if you?re still facing the same issue. If this step doesn?t work, please do let me know and I will give you the more complicated method of resolving the issue 🙂 🙂 🙂

      Please post back if you have more problems or questions.

      • #2550358

        Office 2007 Spell check issue Harder Virsion….

        by Anonymous ·

        In reply to Office 2007 Spell check issue….

        Examine the Proofing Tools portion of the Windows registry on a known good and a known bad system. The Proofing Tools information in the Windows registry is located in “HKEY_CURRENT_USER\Software\Microsoft\
        Shared Tools\Proofing Tools\1.0.” On the system whose spelling checker did not work, there existed a subkey named “Override” within the “1.0” key. The known good systems did not have an “Override” subkey.
        After digging a little deeper, I noticed that the two REG_SZ values in the “HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools\1.0\Override\en-US” key pointed to files that were non-existent.
        So to solve the problem, all youneed to do was to delete the
        “HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools\1.0\Override” registry key. Once this was done, simply by closing and restarting Word, you are able to verify that spell check is once again working.
        While for three desktops this may not be a big deal, if you need to remove the Override registry key from dozens to thousands of computers, you probably want an easier way. By default, non-administrators have write permission to their account (HKEY_Current_User) registry hives, so an easy way to apply this fix would be by using the Reg command in your login script. For this specific problem, you ould need to run the Reg command with the following syntax:
        Reg delete “HKCU\Software\Microsoft\Shared Tools\Proofing Tools\1.0\Override” /f
        The /f switch forces the command to delete the key without prompting for user confirmation.
        With multi-language support ingrained in the Office 2007 proofing tools, it’s also important to ensure that a user’s Word environment is not set to use the wrong language by default. You can verify the default language settings for a user’s Word environment by following these steps:
        1.Open Word 2007.
        2.Click the Office icon in the top left corner of the window and then click the Word Options button.
        3.In the Word Options dialog box, click the Language Settings button.
        4.Finally, ensure that the correct language is selected in the Primary Editing Language drop-down menu.

        Please post back if you have more problems or questions.

        • #2660425

          thanks for the responses!

          by mbwmn ·

          In reply to Office 2007 Spell check issue Harder Virsion….

          thanks to both GoJinks And Peconet for their responses. i googled microsofts’ newsgroups and found the registry fix similar to the one above. i renamed the reg key “old” and rebooted. this apparently causes Office 2007 to rebuild it’s proofing tools.

          problem solved!


          thanks again-

        • #2660422

          Nice to know…

          by Anonymous ·

          In reply to thanks for the responses!

          Thank you for your reply. It nice to know it works.

          Please post back if you have more problems or questions.

    • #2550347

      Upgrade copy?

      by gojints ·

      In reply to office 2007 spell check inop

      I had the same problem when upgrading from 2003 to the Beta for 2007 and then the full version. (We hoped the full would fix the problem.)

      Sorry to say, the only way it got fixed was to rebuild the machine and reinstall everything clean. Hope you find an easier way.

Viewing 2 reply threads