General discussion

Locked

permissions in Access reports

By wyldwezl ·
I've built an Access(97)database we're beginning to use for our production records. Everything's pretty smooth at this point, but there's one report no one can seem to be able to print without administrator permission. Since we have group security set up, most users have limited access to the inner workings of the thing. However, out of all the reports I've made up, this is the only one that won't allow non-administrators to print.

Specifically, the errors says that "you do not have sufficient permission to print rsubBacklogSummaryTotals . . ." The sub-report inside the main report has calculations that are done in the report, not from an outside query. When I go to assign permissions, this particular rsub is not available in assign a permission.

So, I figured to save the rsub as a separate entity. Tried that, still doesn't appear as an object to assign permissions to. I can open the rsub in design view, but there's nowhere I've found to change permission for that specific part of the report.

I'm stumped, and of course, one of two people who can run the report right now. Suggestions?

This conversation is currently closed to new comments.

1 total post (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by mslizny In reply to permissions in Access rep ...

Your error message suggests that only the
Administrator has the rights to the source
object for "rsubBacklogSummaryTotals."

Very simply, if the report uses a part of Access
that users do not have permission for, they will
not be able to open the report. Reports inherit
the permissions from their sources.

Back to Software Forum
1 total post (Page 1 of 1)  

Related Discussions

Related Forums