Question

Locked

PHP 5.2.6 & Apache 2.2

By h.sherzad ·
Can some one help me,
I am trying to install PHP 5.2.6 (windows installer) and use it with Apachee 2.2, it is supposed to work I did all the File copying and the module add stuff as instructed in the "instal.txt" the apache runs alright but it can't recognize any php coding help!

Best regards.

This conversation is currently closed to new comments.

1 total post (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Check your Apache WebServer (httpd.conf) settings

by CodingUnknowingly In reply to PHP 5.2.6 & Apache 2.2

I had lot of issues on Windows Vista Ultimate (SP1) running PHP 5.2.6 after installing it using the Windows installer. The PHP command interpreter kept crashing.

After mucking around with PHP.ini file and lots of Googling... I finally downloaded the PHP Win32 Zip file from PHP.NET site and unzipped it into the existing PHP Folder and that seemed to have worked for me.

Make sure you run - php.exe at command line. That may give you an insight into if PHP itself is happy or not.

As far as Apache configuration goes, here is what I added in httpd.conf file:

....
LoadModule php5_module "C:/Program Files/PHP/php5apache2_2.dll"
...

#PHP Folder
PHPIniDir "C:/Program Files/PHP/"

# 'Main' server configuration
#
.....

<IfModule mime_module>
....
AddType application/x-httpd-php .php .html
AddType application/x-httpd-php-source .phps
...
</IfModule>

It seemed to work for me. Good luck with your installation. Happy PHPing!

Visit me at http://codingunknowingly.blogspot.com

Back to Software Forum
1 total post (Page 1 of 1)  

Related Discussions

Related Forums