General discussion

Locked

pppd on linux

By see7a ·
Hi i have a motorola SM modem
i have a driver for it that requires kernel 2.4.x
so i rebuilt my 2.2 kernel on RedHat7.0 and installed the driver successfully
now when i try to connect to my ISP i dial normally but when the connection is established i get 'pppd died' and i'm disconnected
i tried redhat dialer and kppp and i get the same error
any help?
thanx

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

pppd on linux

by cascom In reply to pppd on linux

From your question I gather this is a "win" modem.
The driver requires kernel 2.4.X because that series kernel includes support for Win modems.
Rebuilding your 2.2 series kernel may allow you to install the driver but it obviously will not work correctly because the other half of the communication required is not there.
Download, build and install a 2.4.X kernel and all will be well...

Enjoy, Linux is GREAT...

Collapse -

pppd on linux

by see7a In reply to pppd on linux

when i said i rebuilt my 2.2 kernel
i meant that i built a 2.4.4 kernel

now every thing works all right
but something is wrong in the pppd
it dies when i establish the connection
i checked the ppp choice in
Network configuration during kernel config before i built it

any help?
thanx in advance

Back to Linux Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums