General discussion

  • Creator
    Topic
  • #2082750

    Problems with Authentication

    Locked

    by legna_fg ·

    Hi linuxers:

    I have probles with user authentication, my Cisco is 2500 configured with tacacs+, and 8 USRobotics modems
    I’m using shadow password
    I have installes tacacs+ in my server, the /etc/tacacs/tac_plus.cfg has the following:
    key = ptoavent
    default authentication = file /etc/passwd
    accounting file = /var/log/tacacs.log
    default authorization = permit

    I get disconnected from server when client tries to check password
    any suggestion?? Thanx guys

    Mario Benitez
    Infoenlace
    Technical Support

All Comments

  • Author
    Replies
    • #3898354

      Problems with Authentication

      by anton_wijaya ·

      In reply to Problems with Authentication

      default authentication = file /etc/passwd

      change it to

      default authentication file = /etc/passwd

    • #3896354

      Problems with Authentication

      by gicu ·

      In reply to Problems with Authentication

      First you should check for this on cisco:
      aaa new-model aaa authentication login default local aaa authentication ppp default tacacs+
      tacacs-server host ip.of.linux.server
      tacacs-serverkey ptoavent

      If all these are ok, then the problem is with format of /etc/passwd file, for example in RH6.1, it’s in another format (because of shadow system) so you shoul create another file with username and password (crypted) in it.

    • #3740005

      Problems with Authentication

      by legna_fg ·

      In reply to Problems with Authentication

      This question was auto closed due to inactivity

Viewing 2 reply threads