General discussion

Locked

qmail don't respond to SMTP client

By chuanch ·
After I install qmail according to Dave's article "life with qmail", I can start qmail on my machine now. But I encounter a weir problem here.
Below is a detailed description of this problem.
When I test my qmail installation, I found I can deliver message through "echo to: me | /var/qmail/bin/qmail-inject ". Here I use my internet email address as the replacement of "me" in that instruction. and I receive this message correctly from my internet mail-box. But when I try to connect to the SMTPport on this machine throught TELNET( telnet 127.0.0.1 25) . I got the message:
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.

I expected see the 220 message below the message above, but nothing comeout anymore.
so when I check trought netstat, I can see a connection has been established to the SMTP port, but I can do noting becuase the SMTP has no further response to other command, no response appears when I type at this situation.

after that, I try to connect to this qmail server throught an SMTP client(outlook express), still failed.

My system environment is: Redhat Linux 6.2, qmail 1.03,ucspi-tcp-0.88, daemontools 0.70. and I've add my client IP address to the smtp cdb file usedby tcprule.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

qmail don't respond to SMTP client

by larryhyman In reply to qmail don't respond to SM ...

I don't think you telnet to the smtp port, I think you have to telnet to the telnet port and try the qmail command at the unix prompt.

I might be completely wrong (because I know nothing about unix, but give it a try)

Larry Hyman
webmaster@pro-staging.com

Collapse -

qmail don't respond to SMTP client

by chuanch In reply to qmail don't respond to SM ...

I use telnet just for testing the correct response from the SMTP service of qmail. All I want to do is send mail through qmail SMTP service from SMTP client such as Outlook Express.

Collapse -

qmail don't respond to SMTP client

by chuanch In reply to qmail don't respond to SM ...

Point value changed by question poster.

Collapse -

qmail don't respond to SMTP client

by xanji In reply to qmail don't respond to SM ...

Check /etc/services if smtp has been enabled.
In the services file use the complete path to tcp-env(eg: /var/qmail/bin/tcp-env) restart inetd and try again.
Also check if smtp port is being blocked by tcp-wrappers or ipchain rules.
smtp cdb is used only while relaying, so it would not come into the picture.
on more thing to check for is sendmail, uninstall it, and also create links using qmail-sendmail wrapper.

Collapse -

qmail don't respond to SMTP client

by chuanch In reply to qmail don't respond to SM ...

I've checked my supervise configuration file and found some mistake in the run script. Thanks!

Collapse -

qmail don't respond to SMTP client

by chuanch In reply to qmail don't respond to SM ...

This question was closed by the author

Back to Linux Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums