General discussion

Locked

Quicktime kidnapped Media content

By DEAKB ·
Hi
Installed iTunes and got QuickTime installed at the same time. Now iTune is a sound player I could live with. But it also got me QuickTime which have the annoying habit of playing any video clip inside a IE-window. Previously I got the Windows Media Player launched and I was happy with that.

How do I get rid of Quicktime without killing iTunes? Uninstalling QT killed iTunes. Setting QT so that it only should manage QT-specific format doesn?t do it either. I want mp3, podcasts, web-radio in iTunes and Video / Movies in WMP.

Does anyone know how to cure this?

//Dan-Erik

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

yup

by Jaqui In reply to Quicktime kidnapped Media ...

right click on a video file, and select open with
then pick wmp and check, always use this program to open this type of file.

or, using windows explorer, go to tools, folder options, file types tab
select the video types, one at a time, and change the application association.


then, also, delete the qt plugin from your ie plugins folder.

Collapse -

sorry... that didn't do the trick

by DEAKB In reply to yup

Sorry. Theres gotta be something more to it? The QT plugins are gone. Both in Programfiles/IE/PLUGINS and in Programfiles/QT/Plugins.

Any application association is either WMA or (if they where QT-unique formats) gone. Cleared the IE cache and rebooted and still a movie clip comes up in a IE-window with QT rather than launching WMA.

QT = Malware?

Got any other ideas? Regedits? If so, where?

Collapse -

YOu missed something.

by faradhi In reply to sorry... that didn't do t ...

An easy way to be sure you get all format that can be played in WMP to use WMP is to reinstall/Repair WMP.

No QT does not equal Malware. When you installed I-Tunes, you were given the opportunity to use the advanced install. Within that install you would be given the option to edit the file associations. Don't blame quicktime or Itunes because you decided to take the quick route an selected the default install or you failed to look closely at the file associations.

Collapse -

I did use the advanced setup...

by DEAKB In reply to YOu missed something.

I did use the advanced setup and made sure no file assosiations where set to QT (other than 2 that are QT unique and I couldnt deselect).

The key issue is that evey clip stored on my local computer does open with WMA. It's only when you click on an mpeg in IE that it behaves strangely.

But I'll get WMA reinstalled and see if that does the trick. Thanks for the tip.

Comment though, for me the malware could be open for discussion ;-) Incidentally I did write it as a joke. Should have added a smiley though. I thought that joke was obviuos. Appologies, want forgett again.

//deakb

Collapse -

Sorry If I was a little abrupt.

by faradhi In reply to I did use the advanced se ...

I was just coming from dealing with an idiot that insisted his computer was broken be he could not get a web page. I guess I transferred a little to you. I apologize.

The definition of MALWARE is getting a little liberal lately. MALWARE is all about intent and knowledge of changes. It seems that I am constantly fighting anti-spyware programs because they list programs like the sysinternals utilities and VNC as Spyware. While those programs could be used as spyware, they are not MALWARE. These tools are invaluable for System Admins.

I have installed quicktime on multiple machines (about 500). It seems every academic program uses the QT components. I have not experienced the problem you described. Also, quicktime does offer a standalone installer that does not include Itunes.

Collapse -

I-tunes itself is

by Jaqui In reply to YOu missed something.

malware.

since I have no need of i-tunes, and needed quick time, I was right pissed with apple for not allowing a quick time only install.
[ they still do not allow quick time only install ]

danged malware, installing crap that is not wanted.

I went and downloaded sources for a lib that added support for quick time video formats to my normal video player..Xine. got rid of the malware crap

Collapse -

The issue is sorted, the discussion?

by DEAKB In reply to I-tunes itself is

Thanks for the help I got.

I managed to sort the issue by reinstalling WMA and removing a QT registry entry associated to QT under the Internet Explorer key. That did it. Now a video clip is once again launched in WMA rather than inside a IE-window with QT. And iTunes work as well.

But I do find it somewhat frustrating that large corporations cant keep there fingers of other parts of a computer than what the software is supposed to do. E.g. iTunes recives greate reviews as a music player (which it is) and for some odd reason they have to tie this to additional video-software.

I guess one have to live with it, but I still call that ?#%&!/ close to malware.

Thanx for the support anyway...

//deakb

Back to Community Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums