Question

Locked

Screen goes black after installing graphics driver.

By ameliachida ·
Hi. I have a toshiba satellite A200 that has the Video Adapter Mobile Intel(R) 965 Express Chipset Family (256 MB)
The computer started to be very slow and since i had a lot of programs i didnt wanted anymore i restored it to the out of box state.

The problem is that the screen went black after the windows logo. It only worked in safe mode. I deleted the drivers of the display adapters and it works but without a graphics card.
Now i cant play games or watch movies. Everytime I try to install the driver, no matter if its from the cd, the toshiba webpage or the intel webpage it always restarts with black screen.
I tried to disable the adapter instead of uninstalling it. When I enable it, it accepts it and it will say its working but just with 640x480 screen resolution. If I try to put it higher it always goes black.
Can anyone help me? Thanks so much

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

I can't find an A200 with an Intel 965 chipset ...

by OldER Mycroft In reply to Screen goes black after i ...

I've found an A200 with an Intel 945 chipset but it's got an Nvidia Geforce Go 7300 graphics processor.

What graphics driver are you installing?

Collapse -

Intel 965GM Display Driver theres none of Nvidia

by ameliachida In reply to I can't find an A200 with ...

I bought my computer in Australia SATELLITE A200 (PSAF3A-08202D)Im gettin the driver from that webpage. Its called Intel 965GM Display Driver, thats all it says. That driver is also in the dvds that came with my computer.
I havent found anything that says nvidia in my computer display. With the program everest all it says is
Video Adapter Mobile Intel(R) 965 Express Chipset Family (256 MB) and 3D Accelerator Intel GMA X3100

Hope you can help me Im really confused about whats happening. Thanks

Collapse -

Try this link: ...

by OldER Mycroft In reply to Intel 965GM Display Drive ...

Apparently when the initial drivers (like the ones on your install disc) were released, there were a few bugs - one of which was to reduce the display to default resolutions, from where it was difficult to recover.

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProductID=2800&DwnldID=17407&strOSs=154&OSFullName=Windows%20Vista*%20Business,%2032-bit%20version〈=eng

I've followed a path all the way from the descriptive given on the Toshiba.Au site (I'm assuming your OS is Vista Business).

Let us know if it works.

*Just a thought:
It may turn out that you will have to reinstall from scratch BUT NOT install the default graphics drivers, instead installing the updated drivers instead.

But DO try the above link first. :)

Collapse -

Nothing

by ameliachida In reply to Try this link: ...

Well Thanks for the link but i tried installing it and again the black screen. I tried to do it from scratch and nothing..black screen.. any more ideas? Thank you so much.

Collapse -

This is worth a try.........

by ThumbsUp2 In reply to Screen goes black after i ...

In the old Win98 days, we used to have to reset to Windows Standard VGA driver, uninstall the card and reboot. It would come back up looking real ugly, but we were then able to run the video installation and let it auto-detect to find it.

I haven't looked in so long, I don't know. Will WinXP let you do that? It's worth a try.

Back to Storage Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums