General discussion

Locked

Set file permissions using WinInet FtpCommand

By tcruise ·
I'm trying to use the FtpCommand function in Microsoft's WinInet.dll library to set file and directory permissions on a UNIX FTP server.

When I run the following command from the MS DOS FTP client, it works and returns the following response:

ftp> quote site chmod 0700 mydir
250 Changed.

When I try to issue the same command via the FtpCommand function, it fails. Here is the response I gete back from the FTP server:

200 Type okay.
200 PORT command successful.
500 Syntax error, command unrecognized.

I am running this command from the root directory.
The directory I am trying to change perms for is directly under the root directory.
I have tried specifying the directory using both "/mydir" AND "mydir".

Any help greatly appreciated.

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Use winsock.

by tbragsda In reply to Set file permissions usin ...

.
I have used that inet dll for FTP for a bunch of stuff. Its very easy to use for the more admin inclined vs. programmer, but it is very limmited. It is also not very reliable. It cant do ascii mode.

I would look for some examples using winsock. I have several of these kicking around, and may post them if you cant find them quickley.

TBR

Collapse -

Wrong forum

by deepsand In reply to Set file permissions usin ...

This is a tech. problem, in search of a solution.

It properly belongs in "Technical Q&A," not in "Discussions."

Please re-post there.

Thank you.

Back to Community Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums