General discussion

Locked

SQL Error

By kashmeir63 ·
Hi,
I'm very new to SQL. I'm running sql 7.0. When I
optimize the database I get the following error:
Error 1105 [sql server] could not allocate space for object (table_name is here) in database because the primary filegroup is full...Is therean easy solution to this.Any help would be appreciated...... I tried the command below but still received the same results

EXEC sp_spaceused @updateusage = 'TRUE'

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

SQL Error

by Joseph Moore In reply to SQL Error

I am using SQL 2000, but I believe the terminology is the same with SQL 7.
Open up Enterprise Manager. Expand the Server Group, then your SQL server, Databases, and then right-click on your database that is giving you the error and choose Properties.
On the Data Files tab, is Automatically Grow File checked? If so, in the Maximum File Size section, do you have selected Unrestricted File Growth?
Basically, you should have these options selected. If not, then your Data File will be limited in how large it can grow. And once you hit this threshold, it won't grow any larger, which could be the cause of your problem.

Also, the same goes for the Transaction Log tab.

Lastly, the Filegroups tab, do you have Read Only checked for the Primary filegrouup? If so, I would uncheck it, so more data could be written to the filegroup.

hope this helps

Collapse -

SQL Error

by kashmeir63 In reply to SQL Error

Poster rated this answer

Collapse -

SQL Error

by kashmeir63 In reply to SQL Error

This question was closed by the author

Back to Software Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums