Question

Locked

Sybase

By lloyd.earle ·
unable to connect IM003] Specified driver could not be loaded due to
system error 126 (Sybase System 11).

this is the message i'm getting when i try to connect to sybase any help will be appreciated.

This conversation is currently closed to new comments.

1 total post (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

This might fix it...

If there was a previous version of open client installed, it is recommended that it be removed and the registry entries be cleared before installing the newer version. If the previous installation was 11.1.1 there should be an uninstaller on the original cdrom. If not, remove the directory and reg settings manually.

from solved cases on sybase site :

First of all, make sure all the environment variables are set correctly.

$SYBASE
$SYBASE_OCS
$PATH - contains bin and dll in the path. Make sure, that you code is not resetting any of these variables.

Next,
The 126 error is normally due to older versions of the DLLs being picked up. You'll need to remove the following files and rerun the setup.

The resolution to the problem is to delete all copies of the following WinNT/Win95/Win3.x Sybase ODBC files:
1)
sysybnt.dll/sysyb95.dll/sysybw3.dll;
sybasnt.dll/sybas95.dll/sybasw3.dll;
syutlnt.dll/syutl95.dll/syutlw3.dll and syodbc.lic.

2) Reboot the machine.
3) Reinstall ODBC.

http://www.dbforums.com/showthread.php?t=1217503

Please post back if you have any more problems or questions.

Back to Software Forum
1 total post (Page 1 of 1)  

Related Discussions

Related Forums