General discussion

Locked

Upgrading to KDE 2.0 on RH 7

By ddiall ·
I've downloaded all the latest (23-X-200) RPM files for KDE 2.0 from a mirror site (just like the one on ftp.kde.org). Then I tried to upgrade (rpm -U) the KDE 1.2 packages, it didn't work for some dependencies issues.

Ok, I removed (rpm -e) all the old KDE packages and tried to install (rpm -i) the new ones. I think I got, more or less, the correct order to add the RPMs: kdesupport, kdelibs, kdebase, etc... But, for my surprise, it still complained from dependecies problems, even for the first package.

The lacking feature is 'libmng'. Meanwhile, I have already downloaded the libmng-0.9.2.i386.rpm with the help from www.rpmfind.net and will try it out later.

I think that this may solve the problem, but what I don't understand is why aren't all the necessary packages on one easy to find place?! Why isn't there a README file with all the required packages and the correct order of installation?

Is something escaping from my attention or it is really that hard to upgrade to KDE 2.0?

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Upgrading to KDE 2.0 on RH 7

by randyarnold In reply to Upgrading to KDE 2.0 on R ...

You must first install the qt-2.2.1 package.
Then (as root) run ldconfig.

Randy

Collapse -

Upgrading to KDE 2.0 on RH 7

by ddiall In reply to Upgrading to KDE 2.0 on R ...

Thanks. But I had figured that out already, tho. I checked out the FAQ on 'http://www.kde.org/info/2.0.html'.

Anyway, KDE 2 is a bit "sluggish" and the Konqueror seems cool and powerful, but it is very unstable! It crashes far more frequently than Netscape.

Collapse -

Upgrading to KDE 2.0 on RH 7

by ddiall In reply to Upgrading to KDE 2.0 on R ...

This question was closed by the author

Back to Linux Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums