Question

Locked

WD external hard drive

By Godsmyrmidon ·
Tags: Windows, Hardware
I have a WD 3 TB external hard drive and while using it it fell over now it says the device is working properly but it says "0MB capacity"
i've tried EVERYTHING! i tried downloading a new up date from WD support center
i've tried going into the disk management and getting the new volume and i've tried to change the letter but wont me let me do anything when i right click it
just says "disk 1" or "disk 2" unable to initialize and unable to.... well do anything...
i've tried even buying a newer design but same model of it take it apart and and tried changing the USB connecting part from the actual hard drive hoping that was the problem... oh and i know its the same model because when i took it apart the hard drive in it is the same wd30ezrx
please help i dont know what to do~!

I have a windows 8 computer
i've had this external hard drive for about 2 and half years

This conversation is currently closed to new comments.

0 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Share your knowledge
Back to Windows Forum
0 total posts (Page 1 of 1)  

Related Discussions

Related Forums