General discussion

  • Creator
    Topic
  • #3986926

    What has your experience with nvidia-open been?

    by canoe.company-0a ·

    Tags: 

    I have been using nvidia-open for a while, and I am really surprised how well it works. I was expecting it to have issues, but for my 3080 it seems to be running a few games even better. Close to the sun was rather stuttery initially, but after switching to open module, it’s been running super well.

    I haven’t tested wayland but some hyprland users seem to say it is working with nvidia-open.

    What has your experience been? Are you using it? Any improvements you noticed?

You are posting a reply to: What has your experience with nvidia-open been?

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our Community FAQs for details. All submitted content is subject to our Terms of Use.

All Comments

  • Author
    Replies
    • #3987056

      Can you find that recent news?

      by rproffitt ·

      In reply to What has your experience with nvidia-open been?

      I wish I could find where a bug was found, fixed in the last month or two where Linux Nvidia drivers improved by some hundred percent in performance. The write up was interesting and a testament to making such open source for all to dig into.

    • #3987800

      Reply To: What has your experience with nvidia-open been?

      by appeals.softest-0p ·

      In reply to What has your experience with nvidia-open been?

      I switched from a 5600XT to a 3080 shortly after the release. I was relieved that it was actually a pretty simple swap. I just installed nvidia-open-dkms before putting in the card and it seemingly just works. I have not gotten Wayland to work but I figure that’s a bit of a lost cause at the current moment. I haven’t used their proprietary driver in a long while so I cant speak to how it compares but for an “alpha” quality driver it’s worked as well if not better than I would have expected for NVIDIA on Linux.

      One funny quirk I will say I ran into was Lutris could not detect what type of drivers I was running so it would crash. I manually patched Lutris from a merge on their GitHub and am waiting for the update to hit the arch repos.

Viewing 1 reply thread