Question

Locked

Why am I getting this message?

By rmedinger ·
MMC cannot open the file C:\windows\system32\services.msc

The file exists and I am the admin on the machine. This just started happening.

This conversation is currently closed to new comments.

12 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

How are you trying to run it?

by seanferd In reply to Why am I getting this mes ...

Try just opening the console by typing
MMC
into the Run box. Does it work? Can you then load the services snap-in?

If not, try running
sfc /scannow
from the Run box.

OS and setup (network, PC, server) may be of use if further troubleshooting is required.

Collapse -

Running through exe files.

by rmedinger In reply to How are you trying to run ...

I am trying to run an executable and I get the error message. I just ran sfc/scannow, and there was nothing that resulted from that. I was not at the screen when it finished, but there are no messages, it just closed normally.

Collapse -

What EXE files?

by seanferd In reply to Running through exe files ...

The only EXE for the console is mmc.exe. All the snap-ins, like Services, are .msc (e.g., services.msc).

Did you try running the console by itself, then adding the snap-in. Instructions in previous post.

If nothing is working, you can re-install the MMC by downloading it from Microsoft. If you don't have it, MMC 3.0 is a better version than previous ones.

Collapse -

MMC info

by rmedinger In reply to What EXE files?

I took your advice and downloaded MMC from Microsoft, and when I tried to install it (XP version), it says it is older than the present version. Does that mean I have a "wrong" version on my machine? If so, do I need to remove it and load the latest XP version from MS?
Thanks for your help.

Collapse -

Try Jacky's suggestion below.

by seanferd In reply to MMC info

If you already have 3.0 installed, do not try to install an older version.

Collapse -

See if this will help

by Jacky Howe In reply to Why am I getting this mes ...

You receive a ?Cannot open <Snap-in Name>? error message when you try to start MMC on a Windows XP-based computer

To work around this problem, turn on the Offline Files feature on your Windows XP computer. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
307853 (http://support.microsoft.com/kb/307853/ ) How to use offline files in Windows XP


http://support.microsoft.com/default.aspx?scid=kb%3Ben-us%3BQ326574

Collapse -

MMC Problem

by rmedinger In reply to See if this will help

I'm not trying to start MMC directly. I get the message when I try to start other programs.
Thanks.

Collapse -

services.msc

by Mehul Bhai In reply to MMC Problem

Type only "services.msc" (without inverted commas, naturally) in the "Run" and click "OK" button and see what happens.

Collapse -

File Association

by Mehul Bhai In reply to services.msc

If you are still not able to open then there may be a file association problem for the file extension ".msc". You can add/associate mmc with ".msc" extension in the "File Types" Tab of the "Tools >> Folders Option" Menu pop-up from the Windows Explorer.

Collapse -

Hotfix

by rmedinger In reply to File Association

There is a hot fix for this exact error message, but I download the fix and then unzip it. When I run it, it seems to run, but there is no result window and I'm still getting the error message when I try to run services.msc from the run window.

Back to Software Forum
12 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums