Question

  • Creator
    Topic
  • #3937823

    Windows 10 OS

    by tech_man0001 ·

    Here’s one I haven’t seen before, in System properties there is no OS listed. I am running Win 10 pro on a 64bit architecture with Windows 21H1 installed. It boots from EFI so not a BIOS thing. When attempting to install 21H2 it kept saying “update completed but can’t tell if PC is ready to update” when I looked in system properties I noticed no OS was listed as a default. Win 10 is the only OS on the PC and never dual booted. I believe this is related to the failed update but could be wrong and they are two unrelated issues. I also tried to update to Win 11 but same message, and all it will let me do is do a full install which I am not really wanting to do.
    Thanks for any assistance.

You are posting a reply to: Windows 10 OS

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our Community FAQs for details. All submitted content is subject to our Terms of Use.

All Answers

  • Author
    Replies
    • #3939685

      Re: Windows 10

      by kees_b ·

      In reply to Windows 10 OS

      It seems the OS is in some way corrupted. In such a case, if you have no image backup to go back to, a clean install might be the only solution, even if it’s not the one you prefer.

    • #3940429

      RE: Windows 10 OS

      by bart_0sh34 ·

      In reply to Windows 10 OS

      Hi,
      there are only 2 reasons if the installation doesn’t work and if it’s not the BIOS it’s probably a Corrupt System Files.

      In this case, you can do it manually by going to: https://www.microsoft.com/en-us/software-download/windows10. Here, click the Update Now button and allow downloading the software. Then, as an administrator, run the update assistant and follow the prompts to finish the upgrade.
      Now restart your computer, and check to see if your system’s Windows version is 21H1.

      Let me know if it worked.
      Cheers

      • #3940415

        re: Windows 10 OS

        by tech_man0001 ·

        In reply to RE: Windows 10 OS

        It has been updated to 21H1 I discovered the missing OS info when attempting to update to 21H2. When trying to update, is when I get the message and the update doesn’t fully install

Viewing 1 reply thread