Question

Locked

Wine, World of Warcraft, and weird mouse problems

By medullaoblongata ·
I've been attempting to get World of Warcraft to work using Wine on Debian Linux but keep running into problems. I figured I'd post here to see if anyone here had some advice.

I know that Cedega is probably a better option, but I'm stingy and want to see if I can get it to work in Wine so I can spare the subscription cost if I can.

Here's the details:

My laptop is running what has been called a Knoppix Frankenstein version of Debian (that is another story) and had initially been running version 9.25 of Wine. I had WoW installed on another Windows machine and so I merely copied the whole directory into my Wine directory on the laptop.

I made some regedit modifications and added a few lines to the Config.wtf file and was able to get into the game. It seemed to run smoothly but the one problem was that the minimap was white in cities and buildings. I read that later versions of Wine corrected that problem, but I was having difficulty installing an updated version.

Well, the new stable release of Debian came out just a week or so ago and an updated version of Wine became available, version 9.31. I was anxious to test out WoW after the upgrade and then realized that WoW had a patch too. The patch managed to download and install without having to do anything special.

Now when I load up the game, the minimap is fine, but I have a new problem involving the mouse. When I click on anything that isn't a menu, it changes the camera angle. So I click on an NPC and I am suddenly looking at my character from above. Every button on the mouse does the same thing. I can use the keyboard fine and can use the mouse to click on the various menus, but any click done in the viewing area just moves to a different camera view.

I have searched all over the place and no one seems to be reporting this same error. I found a mention about a mouse problem in 2005 due to a WoW patch but none of the suggestions fixed my problem. I also experienced some problems with the game locking up on me and other people have reported that problem with ATI (I have a ATI Mobility Radeon X300) cards since the last WoW patch. I've experienced some of that, but have managed to mostly get past that problem.

I've tried the following things:
1. Added these lines to the Config.wtf file:

SET SoundOutputSystem "1"
SET SoundBufferSize "150"
SET gxApi "OpenGL"
SET ffxDeath "0"
SET ffxGlow "="
SET lastCharacterIndex "2"
SET UnitNameNPC "1"
SET cameraView "4"

2. Added these lines to my X11.cfg file based on advice for the machine locking up with ATI cards:
Option "Capabilities" "0x00000800"
Option "UseFastTLS" "off"
Option "KernelModuleParm"locked-userpages=0"


3. In Winecfg I've changed the Windows version to XP, 98, and ME, but it didn't run differently than it does with 2000.

4. Tried starting WoW with this command: WINEDEBUG="fixme-all" wine ~/.wine/drive_c/program_files/wow/wow.exe -opengl

Any other advice that anyone can give me on how I might be able to fix the mouse clicking problems?

Thanks in advance.

Edit: I've made a breakthrough on the problem. I've been using WindowMaker as my window manager and decided to start WoW using FluxBox instead. The mouse problem disappears and the game runs smoothly. I also tried Sawfish and it also did not have the mouse problem.

So my revised question would be, does anyone have any idea on what could be causing the problem within WindowMaker?

This conversation is currently closed to new comments.

1 total post (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Answers

Back to Software Forum
1 total post (Page 1 of 1)  

Related Discussions

Related Forums