WINXP SP2 Fails to Upgrade

By klh456 ·
I am trying to upgrade a machine from WINXP SP1 to SP2. It failed when trying to upgrade through WSUS. I tried it manually and it gets to a point where I get a message, Setup cannot copy the file acgenral.dll. It is looking in c:\windows\apppatch. I checked and there is a file in that directory with the correct name. Has anyone see this and know how to solve it?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

WINXP SP2 Fails to Upgrade

by orges.h In reply to WINXP SP2 Fails to Upgrad ...

I have the same problem with my home PC. Trying to upgrade SP2 in order to restore some missing files. I suspect the ROM drives are responsible because i tried twice, with a CD-RW and a DVD ROM, the same problem persists. Before the upgrade attempt i tried installing 2 PC games and even though the setup succeeded the installations were both faulty. I tried again with both devices. There may be smth that is affecting the proper operation of the ROM and RW drives. Now I just want to get rid of the unsuccessful setup that keeps trying every time i start my PC. I always need to be in front of the PC now to choose between setup and previous sys in a 3 sec time frame. Any help on how to get rid is highly appreciated.

Collapse -


by shamusleary In reply to WINXP SP2 Fails to Upgrad ...

Delete the AcGenral.dll file from C:\Windows\AppPatch and retry. It will continue.

Collapse -

Check this Microsoft Knowledge Base bulletin:

by nepenthe0 In reply to WINXP SP2 Fails to Upgrad ...

Related Discussions

Related Forums