General discussion

Locked

100% Utilization

By Q2Ggirl ·
What can I do to troubleshoot a NetWare5.0 Support Pack 6a server that intermittently goes to 100% Utilization between midnight and 4AM?

By intermittent, I mean that it might go weeks or months with out doing it and then do it twice in the sameweek.

Also, if I delete the dstrace.log because over the years the file size is enormous, will it create another one? Will I be able to delete it, or will it be in use?

Thanks for your help and suggestions.

This conversation is currently closed to new comments.

14 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

100% Utilization

by rbgnr111 In reply to 100% Utilization

it's probably some application that is running
between those times.
like a backup, or a virus scan.
if it also abends, look at the abend log and it
may give you some insite into what is causing
the issue.

Collapse -

100% Utilization

by Q2Ggirl In reply to 100% Utilization

It never abends and the backup completes before midnight.

Collapse -

100% Utilization

by pierrejamme In reply to 100% Utilization

If you are using compression, what is your schedule for compression? Does it start at 0 hour? Probably, as that is the default.

Collapse -

100% Utilization

by Q2Ggirl In reply to 100% Utilization

The hardware does the compression. As I stated before the backup job is done wherever the server sky rockets to 100%. Did I answer your question?

Collapse -

100% Utilization

by Q2Ggirl In reply to 100% Utilization

Also, the interittent part is why I am having problems troubleshooting.

Collapse -

100% Utilization

by pierrejamme In reply to 100% Utilization

I believe you missed the point. NetWare files that need to be re-compressed are normally compressed at night. Default "Compression Daily Check Starting Hour" is 0.
You can see this in Monitor-Server Paramters-File System Parameters.
A Novell document "How to Force Immediate Compression of Files on a Volume? - TID10020142" also sheds some light on the problem.

Collapse -

100% Utilization

by Q2Ggirl In reply to 100% Utilization

I checked the settings. Right now it is set for the following:

Compression daily check stop: 6
Compression daily check start: 0

Do you think that this is really causing the problem? The backup job is always complete around 12:15AM on average. So does this mean that in the last 15 minutes of the backup, the server is starting to try to compress files and makes the utilization shoot up and get stuck?

Thanks for all your help, I'm only a CNA and have never had to alter these settings. What do you suggest I set them on? Will I have to reboot the server for the new settings to take effect? What else will this affect?

Collapse -

100% Utilization

by Network Ken In reply to 100% Utilization

I have occasionally had similar problems and it was usually backup related. Depending on how critical this server is you may be able to change its backup shcedule to only backup once a week just to see if the high utilization correlates with that.
And when the High utilization is going on, go into Monitor and look at Kernel, Threads. This will show you a list of top cputime-consuming threads. This should give you a clue.

Also, several times that this happened to us it turned out to be dueto some rogue users running 2k/XP with the MS Client for Netware Services. It seems to happen a lot with a SourceSafe database some of them use when the MS client locks files and never unlocks them because one of their pc's crashed.

Collapse -

100% Utilization

by Q2Ggirl In reply to 100% Utilization

Poster rated this answer

Collapse -

100% Utilization

by nwadmin In reply to 100% Utilization

Check if "client file chaching enable" is off: default. Check in monitor under server paramenters\ncp. I had the instance that this was set to on with service pack 2 (fixed in 2a) and caused random 80% to 100% util on my 5.1 server! Backups ran twice as long/client connections would hang and then drop the netware client on the workstation! This happend even with no users on the server the util would spike.

Check backup software and make sure the product doesn't do somekind of database purge\prooning at that time. I use acrserve 7 and at midnight is when arcserve does maintanace on its databases.

Copy the dstrace.log file away for backup\troubeshooting sake. I have always been abled to delete the file at any time! It will be recreatedautomatically by system if needed!

Back to Networks Forum
14 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums