Question

Locked

128 MB flash drive I/O error

By blakestratton ·
I have this problem with my 128 MB flash drive. Whenever I try to save anything on it, it says "Cannot copy *file name here*. The request could not be preformed because of an I/O device error."
I can open then the files on the dive, I just cant save anything to it now. It just started happening. I tried all the usb ports, and I tried it on another computer. No luck.
I tried reformating it. No luck. Can anybody help me?

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

* Try this One *

by internetspider In reply to 128 MB flash drive I/O er ...

Yes!

if u cannot format it and giving I/O error.
so its finished, destroy it.

it is non repairable. if it is under warranty , try to change it from where u bought it.

Thanks

Collapse -

....."so its finished, destroy it." - Eh?

by OldER Mycroft In reply to * Try this One *

Is that the best you can come up with?

If your gonna be SO TECHNICAL as to tell the poor person to destroy it, at least have the decency to illustrate the BEST MEANS of achieving this objective!

How would you destroy it?

More importantly, why would you destroy it?

It's not in immediate danger of self-combusting is it?

Collapse -

Is the "write lock" on ?

by ugadata In reply to 128 MB flash drive I/O er ...

Similar to floppies there is a write lock switch on the USB drive to prevent writing to the device.

However, I would think that also prevents reformatting the device as well, which possibly indicates a defective USB drive.

Collapse -

SanDisk 2GB (Cruzer Micro Skins 2GB)

by mathewsml In reply to 128 MB flash drive I/O er ...

As you explained, I also faced the same problem. I can read all contents from drive, But unable to write. Even I tried to format, Lo luck, I/O error.

When I contacted, Sandisk they asked me to send it to them and they are ready to provide replacement.

Back to Hardware Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums