Question

Locked

160 Gb HD trying to read

By sreed53 ·
I have a 160 Gb Deskstar (PATA - I think EIDE) out of an eMachines T6212. My brother had the misfortune of having his CPU cooling tower mount break while transporting it to me so I could move his software & data into a new (2 him) PC I refurbished for him. I have tried installing the drive as a slave in the new machine but it didn't have a PATA controler so I tried installing it in one of mine. It will install & spin up but I can't access anything on the drive. Says it's a healthy active FAT32 partition but will not let me assign a drive letter nor see data. I plugged it into a IDE/USB cable set & get the same basic response. Computer Management sees it but I can't DO anything with it. Any Ideas ???
I just need to copy the data I have a new SATA drive for it. ..... Thanks

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Bios update?

by robo_dev In reply to 160 Gb HD trying to read

Lots of times a drive larger than 128GB won't be recognized properly in some PCs.

Either make sure the bios has 'large LBA' enabled and/or be sure your bios is up-to-date.

I had this problem just last week with an intel mobo and a 200gig hdd. A bios update fixed it. The weirdest thing was that the drive worked for about a year in the same machine, then one day would no longer boot. A bios update fixed it instantly. A clue was that in the bios setup screen the drive capacity was listed wrong.

What OS are you using to view it?

Pre SP1 XP won't work with larger drives, typically.

Back to Hardware Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums