Question

Locked

2 Issues with Remote Desktop Incoming Connections

By richard.gostautas ·
Greetings all,

I currently have two separate issues that I am trying to resolve with incoming connections. Information is as follows:

OS: WinXP Pro (2002 version) with SP3
Modem Type: CDMA Wireless Modem

I have no problem with the "Outgoing" connection set up through the Network Connection Wizard. The issue is that when I set up the incoming connection - 2 things seem to happen. 1) The user defined initialization string appears to run but is then over written by some other process (which I cannot track down) and 2) Once I create the incoming connection, I can no longer connect to the modem via Hyper Terminal to check the settings (I get an error saying another program/
device is using the modem and to close it).

These are the following steps I performed to create the incoming connection:

1) Install the wireless CDMA modem using the Add Hardware Wizard. Hardware Connected>Add new device>Manually Select Hardware>Modems>Don't Detect>Have Disk>Chose the .inf file for the
wireless CDMA modem>Selected Port=Com1>Driver not signed by Microsoft>Continue Anyway>Finish.

I can run Hyper Terminal (Test>Ok>Com1>Set modem speed, 8,N,1) and run AT commands to check settings. By default, the CDMA modem is set to ATS0=0 (no Automatic Answer). Now I can run AT+CICB=0 and ATS0=2&W to write it to memory and appears to take. No issues at this point.

2) Create the "Outgoing" connection via Wizard: Connect to Internet>Setup manually>Connect using dial-up>Name "Outgoing">Phone #777 (Verizon network)>No username/password and check to use this account name/pass and make default internet connection>Add shortcut
(modem dials out without any problems)

3) Create the "Incoming" connection via wizard: Set up an advanced connection> Accept incoming connections> Selected MutiTech Systems CDMA Wireless Modem from list of connection devices> Select Do not allow VPN Connections> User Permissions: Allowed to connect: Administrator
(password set for this account)> Networking Software: TCP/IP, Qos Packet Scheduler, File and Printer Sharing, Client for MS Networks
(all checked by default and nothing else changed here)> Finish

Once the above connection is created - the TR (Terminal Ready) light comes on. If I try to connect to the modem with Hyper Terminal - I now get an error that says the device is already in use...hmmm...

4) Since the modem by default is set to ATS0=0, I perform the following steps to add extra initialization strings to make sure the
modem is in the proper mode and set for autoanswer: Control Panel> SystemProperties> Hardware> Device Manager> Modems> MultiTech> <right click>Properties> Advanced> Extra Initialization commands: ?S0=0+CICB=0? (without the quotes of course and should set the type of
incoming calls to data ? we are dialing in to the system with a regular modem)>OK>OK

5) Under Network Connections, <right click> Networking> Click on TCP/IP> Properties> Checked ?Allow callers to access my local network?> Specify TCP/IP range >OK>OK

6) Control Panel> <double click> System> Remote> Checked box to ?Allow users to connect remotely to this computer?

After the above setup ? the incoming connection will work 1 time and will not work after that. Rebooting the system to restart everything
and reinitialize the modem does not work.

In order to get HyperTerminal to connect to COM1, I have to delete the incoming connection from network connections.

The following are the modem settings, I ran hyper terminal to get the following information:
Software Version: AT+CGMR: S/W VER: WISMOQ WZ3.03K Feb 21 2007
09:53:24 (latest drivers)
Capabilities List: AT+GCAP: +CGSM, +CIS707-A, +MS, +ES, +DS, +FCLASS
Phone Functionality: AT+CFUN?: +CFUN:1

Now if I leave HyperTerminal running and dial into the modem, the modem returns the following: RING ASYNC - So I know the modem is at least acknowledging it has an incoming call but appears that the previous setting for auto answer did not take.

So from the Device Manager, I run the diagnostic and set run the log. The following is the output after I reboot the system:

<REBOOT SYSTEM>
08-04-2008 16:32:51.468 - File: C:\WINDOWS\system32\tapisrv.dll,
Version 5.1.2600
08-04-2008 16:32:51.531 - File: C:\WINDOWS\system32\unimdm.tsp,
Version 5.1.2600
08-04-2008 16:32:51.531 - File: C:\WINDOWS\system32\unimdmat.dll,
Version 5.1.2600
08-04-2008 16:32:51.531 - File: C:\WINDOWS\system32\uniplat.dll,
Version 5.1.2600
08-04-2008 16:32:51.562 - File: C:\WINDOWS\system32\drivers\modem.sys,
Version 5.1.2600
08-04-2008 16:32:51.562 - File: C:\WINDOWS\system32\modemui.dll,
Version 5.1.2600
08-04-2008 16:32:51.562 - File: C:\WINDOWS\system32\mdminst.dll,
Version 5.1.2600
08-04-2008 16:32:51.562 - Modem type: MultiTech Systems CDMA Wireless
Modem
08-04-2008 16:32:51.562 - Modem inf path: oem10.inf
08-04-2008 16:32:51.562 - Modem inf section: Modem_Wireless2
08-04-2008 16:32:51.562 - Matching hardware I unimodem4d84dec6
08-04-2008 16:32:51.609 - Opening Modem
08-04-2008 16:32:51.609 - 115200,8,N,1, ctsfl=1, rtsctl=2
08-04-2008 16:32:51.609 - Initializing modem.
08-04-2008 16:32:51.609 - CD is high while initializing modem.
08-04-2008 16:32:51.625 - Send: AT<cr>
08-04-2008 16:32:51.625 - Recv: <cr><lf>OK<cr><lf>
08-04-2008 16:32:51.625 - Interpreted response: OK
08-04-2008 16:32:51.640 - Send: ATS7=60+IFC=2,2<cr>
08-04-2008 16:32:51.640 - Recv: <cr><lf>OK<cr><lf>
08-04-2008 16:32:51.640 - Interpreted response: OK
<RUNS USER INITIALIZATION COMMAND>
08-04-2008 16:32:51.640 - Sending user initialization commands.
08-04-2008 16:32:51.656 - Send: ats0=2+cicb=0<cr>
08-04-2008 16:32:51.656 - Recv: <cr><lf>OK<cr><lf>
08-04-2008 16:32:51.656 - Interpreted response: OK
08-04-2008 16:32:51.687 - Waiting for a call.
08-04-2008 16:32:51.703 - Send: ATS0=0<cr> <=Something
is running here that is overriding the previous ATS0=2 command
08-04-2008 16:32:51.703 - Recv: <cr><lf>OK<cr><lf>
08-04-2008 16:32:51.703 - Interpreted response: OK

Short recap: Before I create the incoming connection, I use Hyper Terminal to connect to COM1 (which CDMA wireless modem is connected)
to set CICB=0 and ATS0=2 and write to memory. I create the incoming connection and add "S0=2+CICB=0" to the Extra initialization commands in case the settings do not take. When the system gets rebooted, the command runs but something overrides the custom initialization plus the TR light on the modem goes solid. If I try to connect with Hyper Terminal (COM1), I get an error that it is already in use and to close the other program. So I have to delete the incoming connection from network connections to get it to release and for Hyper Term to connect. Started to think that maybe the incoming connection was running the ATS0=0 command, but even if I delete the incoming
connection setting, I still receive the above output. Needless to say, this defeats the purpose of remote access!

Spent several days and 4 hours with the modem tech support and they are as befuddled as I am.

My apologies for the long post - but hoping someone is sees something we are missing and before I lose my sanity.

Thanks,
Richard

This conversation is currently closed to new comments.

0 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Share your knowledge
Back to Hardware Forum
0 total posts (Page 1 of 1)  

Related Forums