Question

Locked

2 way ping not working

By ebridone ·
hi all,
so i've looking around for a while for answers to my problem that seems to be shared by

a lot of you guys.
here are the facts:
- 2 machines XP SP2 on a linksys lan. Desktop (D) and Laptop (L).
- D pings L, accesses its web pages, telnet, ftp etc...
The problem is with L accessing
- L cannot ping D. It used to work fine until I had to rebuild D as of a HD crash.
- L and D can both see/write each others shared files thru explorer
- L and D can both access internet
- DHCP network.
- windows Firewall is more than set off ie. disabled on both of them (I still explicitly set icmp on in case FW would still do something under the hood)
- connexion is both wired and wireless
- I have no other Firewall installed on any of them
- name resolution works for both of them
- telnet works on default port but no other (like 80 though apache has started

correctly) from L to D (for some reason I can't see the telnet service on L so I can't telnet L)
- L can ping itself and others on the internet.
- I have McAffee security center on both of them.
- Subnet Mask: 255.255.255.0 for L and D
- NetBios and IP Link are set for both L & D, tcp prop is set for IP and dns address determined automagically.
IP addresses are differents when assigned so no conflicts there. All I can think of then is that it could be some services that should be started/configured in a particular if not peculiar way.

Once this issue is solved I'll be glad to share it because of the overstupidness of it.
Any thoughts out there on how to tackle this ?
Thanks

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Re: 2 way ping not working

by michael In reply to 2 way ping not working

I've seen the same bizarre behavior with a co-worker of mine. My PC worked fine, but his would not respond to pings, though his network access was working fine. Did you try this from the command line:

[pre]
netsh firewall set icmpsetting 8 enable
or
netsh firewall set icmpsetting all enable
for *everything* icmp
[/pre]

Please reply either way. I'd like to stay on top of this one.

Michael

Collapse -

FW set and more

by ebridone In reply to Re: 2 way ping not workin ...

I did a reset of the FW and reconfiguration until I decided to completely disable it.
net view of the name computer works fine on each side but not the workgroup (ie net view homelan).
I did a reset of router, all net cards, disabled the wireless connectivity on router and the cards to make the LAN wired only.
I have nwliink netbios and ipx protocols installed coz it used to work this way to help users see/write shared files thru explorer.
What I find utterly odd is that neither D nor L can access the 'homelan' resource that should point to both D and L computers. Desktop can however read/write Laptop.
I guess Rebuilding the network could work but I won't understand anything.

Collapse -

re: can ping out but not reply

by michael In reply to FW set and more

Another co-worker of mine had the same problem. His turned out to be related to running PC-Cillin. Do you have any other "internet security" type software running such as this?

Michael

Collapse -

no Firewalls but

by ebridone In reply to re: can ping out but not ...

Hello,
I am back following up on this issue. Microsoft FW are disabled on both L&amp (including McAfee FW service). I played quite some time enabling and disabling a bunch of services on L & D with no vail.
I recreated the home Lan thru XP set up process.
What I have now is when trying to http D front page, a dial-up box pops up and prompts me to choose the modem connection !?
Also, skype v3.5 is using and messing with port 80.
I am still w/o any clues. Should I use an ip sniffer? Looking for what? Any insight?
Thx.

Back to Networks Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums