General discussion

  • Creator
    Topic
  • #2180048

    4GB of RAM

    Locked

    by tonyemm ·

    Hi Folks,

    I have a PC Intel P4 running Windows XP Pro. A few months ago I installed 4GB of RAM of which only 3GB was reported in Windows. I posted a question detailling my problem and was pointed to the PAE switch in the Microsoft Knowledge base website. This worked fine when I had Service Pack 1 installed, but the moment I installed Service Pack 2 the RAM went back to 3GB. I enclose the Boot.ini file:

    [boot loader]
    timeout=5
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=”Microsoft Windows XP Professional” /fastdetect /PAE

    The Bios is reporting all 4GB of memory.

    Any help would certainly be appreciated.

    Tony Emm

All Comments

  • Author
    Replies
    • #3120103

      Reply To: 4GB of RAM

      by gary56789 ·

      In reply to 4GB of RAM

      Navigate to the following URL

      http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/sp2mempr.mspx

      Then scroll down to the botton of the page “What settings are added or changed in Windows XP Service Pack 2?” and follow the instructions to “manually configure DEP” on your computer.

      Let us know if this works.

    • #3119880

      Reply To: 4GB of RAM

      by master3bs ·

      In reply to 4GB of RAM

      I thought that the 64-bit version of XP was required to fully access 4GB of RAM. Am I mistaken?

      • #2642999

        Yes

        by stargateok ·

        In reply to Reply To: 4GB of RAM

        It is supposed to but, how can you use 64 bit when no programmers or device manufacturers will keep up with the needed drivers?

    • #3117997

      Reply To: 4GB of RAM

      by wcp ·

      In reply to 4GB of RAM

      BIOS flash might help

      I had an ASUS MB whose BIOS read 4GB RAM but Windows showed as 3GB. I did BIOS flash and Windows showed full 4GB. I did not have to use PAE switch.

    • #2643002

      No answers!!!!

      by stargateok ·

      In reply to 4GB of RAM

      Seems like there are no solutions, only more questions tonyemm!

      I have the same problem, only trying to get windows to see 8GB. My moby supports 16GB and during boot-up 8GB is shown, but not when you get to windows. I tried the supposedly current bios for my moby and all it did was lock my computer in boot. I had to re-flash the old bios. I guess no-one has a helpful answer.

Viewing 3 reply threads