Question

Locked

4GB Toshiba USB only shows as 1GB

By JJRichey ·
I have a 4GB U3 Smartdrive flash drive from Toshiba. When I plug it into any computer it only shows up as 1GB, and will only let me put 1GB of data onto it. Anybody know whats wrong? I've tried plugging it into PC's with Window XP Home, Pro, 2000 Pro, and Ubuntuu Linux, and still always shows as 1GB.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Have you tried Disk Management to see the available space?

by wanttocancel In reply to 4GB Toshiba USB only show ...

I would check Disk Management to see if it sees the full size of the disk and the amount of available space.

Also, U3 is an application on the flash drive itself that allows you to run software you might need on other computers without installing that software. Since it is an application it takes up room. Have you (unknowningly) installed any programs onto your flash drive?

BTW: I remove U3 from all of my flash drives because I don't use the application and would like the space to save data but that's just me. Once you uninstall the app though you cannot reinstall it.

Collapse -

Since it shows the same size

by w2ktechman In reply to 4GB Toshiba USB only show ...

on several OS's/computers it is likely not the OS misreading it. It is likely bad memory, take it back and replace it.

Collapse -

yeah

by JJRichey In reply to Since it shows the same s ...

Yeah, it shows as 1.1GB. I figured it out though. Its partitioned! I wasn't aware you even COULD partition a flash drive?! Now I just have to figure how to UNpartition it. I tried a partition manager, but it's not working. It shows up but won't let me merge the unallocated and logical drive into the main partition that I can save onto.... any help with that?

Collapse -

While I havent tried it

by w2ktechman In reply to yeah

I would think that Disk Management should be able to partition it, and format

Collapse -

solving USB problem

by junimtz In reply to 4GB Toshiba USB only show ...

u may have used linux on USB. it might be the cause. so follow these steps.

1) first download easeus partition master
2) open it, u will see unallocated space of your usb, delete your 1GB space of your usb, now all of the space of your usb will merge.
3)Now create new disk space and format it.
4) all of your space will come back.

if u need any help mail me at j_imz@yahoo.com

Collapse -

Reponse To Answer

by wizard57m-cnet Moderator In reply to solving USB problem

After 3 years plus, the OP has probably replaced the USB flash drive.
There's no need to add to an old "zombie" thread. Also, unless you
just enjoy getting loads of spam, you should not post your email address
in these public forums. They are routinely scanned by spam bots looking
for email addresses.

Back to Hardware Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums